Support » Plugin: Table of Contents Plus » Toc not appearing –

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same problem actually. I tested the toc shortcode directly within the template as well as through the content editor in a custom and a vanilla WordPress installations.

    The <!–TOC–> comment is added inside the HTML although no Table is being displayed: https://www.screencast.com/t/zQr5YTatW

    This works when I auto add the TOC though.

    panzerriegel

    (@panzerriegel)

    same problem, table is not showing…

    As of this morning, this just started happening for me as well. Oddly, previous posts still display the TOC where I have placed the [toc] shortcode, but the new post I am drafting does not.

    My experience jives with @gicolek inasmuch that if I force the TOC to display automatically via the plugin settings, it does.

    I rolled back all updates to active plugins that I’ve installed since my last post where the shortcode was behaving properly, but this has not had any effect on the issue. I’ve not installed any new plugins or theme updates in the period since.

    I also tried deactivating and reactivating the TOC+ plugin, to no avail. I’m using WordPress version 4.9.8. Hoping a solution is identified.

    • This reply was modified 10 months, 2 weeks ago by Mr. FFP. Reason: Included reference to additional test of having deactivated and reactivated the TOC+ plugin during testing

    Found what I believe to be a fix — namely, selecting the “show automatically” box in the plugin settings, saving the changes, and then deselecting it and saving the changes. The [toc] shortcode controlling manual placement is now working for me again.

    Hi everybody

    I had the same problem, the [toc] tag was not working with default pages and posts, but working very well with CPTs.

    After analyzing the code and options in the database I found the problem.

    At first I used the plugin with the widget for an automatic summary view and I was not using the tag [notoc].

    I then delete the widget from the site leaving the options set …

    To solve the problem, you have to reset the TOC widget, set the options to empty, save and delete the widget.

    Romain

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Toc not appearing –’ is closed to new replies.