Support » Plugin: Easy Table of Contents » ToC is appearing in the sidebar and footer

  • Hi,

    my theme is using a post/page template (I’m not sure which one) for sidebar and footer. This might be the reason why the ToC is appearing not only inside the post but also in the sidebar and sometimes also in the footer (in the About Me section above the profile photo). Please, see the example here.

    I’ve tried both shortcode and the checkbox for inserting.

    In the setting, the support of ToC is enabled only for posts and auto insert is off. The position is set for “after the first heading.”

    Do you have any idea why is this happening and if it’s possible to fix it?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Steven

    (@shazahm1hotmailcom)

    @jackoneill

    Please navigate to the Widgets admin page.

    Find the Table of Contents widget.

    Click it, and click the Delete link.

    Hope this helps!

    Unfortunately, I don’t have this option anywhere.

    Widgets https://pasteboard.co/HVnrywh.png

    ToC is inactive widget https://pasteboard.co/HVns4Rq.png

    Sidebar post https://pasteboard.co/HVnrf8z.png

    Plugin Author Steven

    (@shazahm1hotmailcom)

    @jackoneill

    Edit your sidebar post, scroll to the bottom. There should be a Table of Contents section. Disable the option to insert a TOC. Save the sidebar post.

    If there is no TOC area on the sidebar post page, the theme is likely preventing it from displaying and you may have to contact the theme author for support.

    Alternatively, you could try…

    Navigate to the Settings : Table of Contents admin page.

    If there is a sidebar post type listed, disable TOC support on that post type. And, Disable, if listed, auto insert on the sidebar post type.

    Honestly, these are just guesses since the them has “non-standard” sidebars.

    No luck with any of these. The first option: there is no TOC area. The second one: everything is already disabled. I’ve even tried to disable every type and use the shortcode but got the same result. So it’s caused by the theme.

    But thank you for your time.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.