WordPress.org

Support

Support » Localhost Installs » To all people who are experiencing a white admin screen after install on a lamp

To all people who are experiencing a white admin screen after install on a lamp

  • Hello this post is for everyone who is using a linux to run their wordpress site on it and experienced a white screen after install when trying to log in. i Think i solved it (it works on my server anyway)

    step 1:
    nano /etc/php5/cli/php.ini
    and look for the line “memory_limit = 128M” (without the ” “) with CTRL+W
    and change that to “memory_limit = 128M”

    step 2:
    nano /etc/php5/apache2.php.ini
    again look for the line “memory_limit = 128M” (without the ” “) with CTRL+W
    and change that to “memory_limit = 128M”.

    step 3: (only if you have suhosin patch installed)
    nano /etc/php5/conf.d/suhosin.ini
    now look for the line “suhosin.memory_limit = 128” with CTRL+W
    and change it to “suhosin._memory_limit = 256”

    when you use phpmyadmin you’ll see that it’ll say

    “The server is using suhosin. Check documentation for possible problems.” at the bottom of the screen.
    (this could be a bit different since mine is in dutch and i translated it to english but it should look similar)
    click on it and change all evrything it says about suhosin in the suhosin.ini file.

    suhosin.request.max_vars should be increased (eg. 2048)
    suhosin.post.max_vars should be increased (eg. 2048)
    suhosin.request.max_array_index_length should be increased (eg. 256)
    suhosin.post.max_array_index_length should be increased (eg. 256)
    suhosin.request.max_totalname_length should be increased (eg. 8192)
    suhosin.post.max_totalname_length should be increased (eg. 8192)
    suhosin.sql.bailout_on_error needs to be disabled (the default)
    suhosin.log.* should not include SQL, otherwise you get big slowdown

    to the example given.

    Done.

    You should now be able to login as admin as follows:
    http://IP-ADRESS/wp-admin

    when u use different ports on apache it’s as follows
    http://IP-ADDRESS:PORT/wp-admin

    i hope this helped, for me it did. the only thing i cant do is login like this http://WEBSITENAME.com/wp-admin

    but every change you make when you login through ip will make changes to the website.

    if you have questions please ask
    greets bogaardesquat

  • The topic ‘To all people who are experiencing a white admin screen after install on a lamp’ is closed to new replies.