Support » Plugin: WooCommerce » tk_ai cookie served all over the site without Jetpack installed

  • Resolved JLoureiro

    (@pattuka)


    Hi,

    I found a topic with this problem marked as solved but it really is not solved.

    I’ve got my site updated and with tracking switched off.

    tk_ai cookie is served to all visitors and not only to those that log into wp-admin as you state and it should.

    Even more, I have a plugin cookie that let users to switch off advertising and tracking cookies and, when they do this, the only tracking cookie that is served is that one.

    Regards,
    Jaime.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • cadomedia

    (@cadomedia)

    Hi,

    same issue here. Jetpack ist not installed. tk_ai cookie is served to all visitors and not only to those that log into wp-admin as you state and it should: https://www.femmina-belle.de

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hey there,

    I have the latest versions of WooCommerce, WooCommerce Admin, and WordPress installed but cannot replicate what you’re describing; in Incognito Mode my cookies list is completely empty:

    https://cld.wthms.co/miLdUX

    I also created a new user with the Customer role, logged in as that user, and no tk_ai cookie was served.

    Are you testing with only WooCommerce and the WC-Admin plugins enabled?

    JLoureiro

    (@pattuka)

    Hello Thomas and thanks for your answer,

    Because of your answer I tried deactivating all the other plugins except woocommerce.

    It’s curious that the cookie only appears if I activate a cookie plugin. I tried with two different plugins and the behaviour is the same:

    https://wordpress.org/plugins/simple-cookie-control/
    https://wordpress.org/plugins/smart-cookie-kit/

    I don’t understand how that cookie can be served with those plugins activated.

    Kind regards,
    Jaime.

    Plugin Support Mike W

    (@nixiack8)

    Hi all,

    This is part of the WooCommerce cookie track, as I am sure you have seen from this thread. You can go here:

    https://docs.woocommerce.com/document/woocommerce-cookies/

    for information on how to disable this particular cookie. If you run into trouble with it reply here and let me know!

    The tk_ai cookie is displaying on the front end of my site when I’m not logged in and when usage tracking is turned off on the back-end.

    Based on Thomas’ note above, I disabled all other plugins and confirmed that tk_ai is not set when WooCommerce is the only plugin. After turning on all of my plugins one by one, it looks like tk_ai gets set on page load when the Monarch social Media plugin is activated. Sharing in case it’s helpful with investigating what might be causing this.

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hey @mpt1,

    Nice catch, and thanks for sharing what you found. I don’t see any reason to believe there is a bug with WooCommerce here given the conflict testing performed.

    If anyone has any evidence of this happening on a clean site with only WooCommerce and a default theme installed(Storefront, 2019), please let us know.

    The WooCommerce team has now approved a change in class-wc-tracks-client.php that seems to solve the problem. I’ve already made the change on my site while waiting for WooCommerce 3.9.0.

    https://github.com/woocommerce/woocommerce/pull/24798
    https://github.com/woocommerce/woocommerce/pull/24798/files/e22a024473352facdff59394b2aa43e4951f8060

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.