Support » Plugin: All in One SEO Pack » Titles not displaying

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Peter Baylies

    (@pbaylies)

    Craig,

    What’s your site? This could potentially be due to another plugin or your theme. Make sure you have a title tag being output in your header.php, which preferably should just look like this:

    <title><?php wp_title(); ?></title>

    The options for managing this are “Use Original Title” in the General Settings, and “Force Rewrites” in the Performance module.

    Yeti

    (@craigheyworth)

    thanks for the reply.

    Ok I’ll check and see. My site is

    My site is http://frontend.feedandgo.com/v1/

    incase you find anything obvious in the code

    Plugin Contributor Peter Baylies

    (@pbaylies)

    Craig,

    It looks like your title might be getting output early, before All in One SEO Pack has an opportunity to rewrite it. Either that, or there could be another plugin or your theme interfering with output buffering, if Force Rewrites is enabled. If you have a dev site (or if this is a dev site) I’d always suggest trying again with plugins that may conflict disabled, and against one of the default themes that ship with WordPress such as Twenty Eleven or Twenty Twelve. And, it doesn’t hurt to have a backup of your site, either.

    Yeti

    (@craigheyworth)

    Ok. Yeah I’m a little confused with the newer setting of aioseo. I’ve ‘use original titles’ enabled, and Rewrite titles disabled; would any of these settings be causing a problem?

    Plugin Contributor Peter Baylies

    (@pbaylies)

    Craig,

    If you have Rewrite Titles disabled, then your titles won’t get rewritten at all; enable that if you’re expecting All in One SEO Pack to do anything with your title tag. Next step, if nothing changes, try setting ‘use original titles’ to Disabled.

    Yeti

    (@craigheyworth)

    oh, and i’ve this in the header

    <title><?php bloginfo(‘name’); ?> <?php wp_title(‘ – ‘, true, ‘left’); ?></title>

    Yeti

    (@craigheyworth)

    ah hah.

    The reason I had rewrite titles disabled is that I presumed it would automatically enter the title I’d given it in the posts, however rewrite them would auto generate it’s own content based on the post / pages name and content.

    I think it seemed to have done the trick. Just checking it’s using my custom titles now

    Yeti

    (@craigheyworth)

    yep… that solved it.

    Thanks for you help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Titles not displaying’ is closed to new replies.