Yoast SEO
Titles & Metas : Post Types doesn't show non-public but publicly_queryable PT (1 post)

  1. Ruud Laan
    Posted 2 years ago #

    WordPress version: 3.5
    WordPress SEO version:

    I did this: Made PT with:
    'public' => false,
    'show_ui' => true,
    'show_in_menu' => true,
    'publicly_queryable' => true

    I expected the plugin to do this:
    Show me this PT in the Title & Metas PT list (in order to set the 'noindex,follow' meta tag on.)

    Instead it did this:
    PT doesn't show up.

    Workaround: set 'public' to true, make settings, return 'public' to false.

    Joost: what I was trying to do here is to protect 'secret' content on a website from getting indexed. The content itself is protected by password, but the title remains readable.
    Thinking in this direction isn't it a good idea to always 'noindex' pages which are protected by passwords?
    Further info: the 'secret' info isn't really that secret at all, it is just that it makes sense for this information to be behind a password to limit access


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Yoast SEO
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic