Support » Plugin: The SEO Framework » Titles appearing oddly

  • Hi Sybre,

    I’m hoping you can help me an issue I’m having with a sub-site – http://www.artiss.co.uk/wordpress.

    I have the following setup in the general options…

    Site title: …On WordPress
    Tagline: David Artiss’ home for WordPress

    However, if I don’t specify any overrides within your plugin I’m getting the following homepage title…

    …On WordPress | …On WordPress | David Artiss’ home for WordPress

    It’s that repeat of the title. Even if I override the settings within your plugin I’m still getting that repeated title.

    I installed the title fix plugin but that didn’t help.

    So, next I tried changing the override title, tagline and description to those exact words so I can see, more easily, how the title is being constructed. I got the following output as the title…

    …On WordPress | title | tagline

    As you can see, it appears to be taking my site’s title but then combining it with the override one. However, if I don’t specify one it’s just repeating the site title again.

    Anything you can suggest will be appreciated.
    David.

    https://wordpress.org/plugins/autodescription/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hi David,

    Looking at the code of the theme you’re using, at least since the update of April 1st, it’s already doing it right :). So the Title Fix extension won’t have any effect.

    If you’re however using a custom or older build of the theme, it might be that it’s then using incorrect standards. For this reason, with the title fix extension, the following filter should overwrite the (sometimes incorrect) check.

    add_filter( 'the_seo_framework_force_title_fix', '__return_true' );

    If that doesn’t work, let’s continue.

    The Home Page has several options within the SEO Settings page, one of which includes where you can remove the tagline, or alter it.
    It defaults to the one given in the General settings of the website.

    Within the additions tab of the Home Page Settings Metabox, you can decide on which side it goes, it should give you a preview of what it should become.

    If those settings don’t reflect its outcome, then there might be a bug present.

    I hope this helps, let me know if it works out :). Have a great day!

    I believe that’s cracked it – thanks Sybre. I added the filter and removed the overrides and it’s now showing as it should.

    I’ll do some more testing, though, and report back if there are any further issues. If not, I’ll resolve this thread.

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi David,

    I’m glad to hear it worked out!
    And yes, it shows <!-- fixed --> next to the title tag. Which is a good sign.

    If anything else comes up, feel free to ask :). Have a great day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Titles appearing oddly’ is closed to new replies.