Support » Fixing WordPress » title-only permalink broken

  • When I change my permalink structure to custom, and put in /%postname%/, it works, and updates my .htaccess file fine; but the actual blog is broken, the links give me an error 404 (not found), and if I edit the URL manually to put in /index.php before the post-name, it works.

    But what gives? I set it up so it’s JUST the postname…

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sorry, I realizise this is an ongoing issue with a lot of frustration for a lot of people.

    If you’re past WP2.01, then I suggest you upgrade to the latest. My solution was to paste the suggested .htaccess stuff wordpress suggested into the file–for some reason, even with the right file access (777, anyone?) it didn’t update properly.

    elihorne

    (@elihorne)

    I’m having a similar problem, although your solution didn’t work for me.

    I went so far as to export my XML file, reinstall wordpress on a fresh database, and then repopulate. My custom permalinks worked for a couple hours, but are now back to generating 404’s like nobody’s business.

    Anyone know whats up with this? I’ve tried switching my permalinks back to less non-standard format (/%year%/%monthnum%/%day%/%postname%/) with no avail.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘title-only permalink broken’ is closed to new replies.