WordPress.org

Support

Title Missing

  • Great plugin but have a challenge. When adding a specific product, it does not display the name of the product. When i leave it to random or pick a category it does display it. What’s the difference?

    Also how do i not display the widget title?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author zorgbargle

    @zorgbargle

    Odd – could you provide some more information: the version of the plugin, as well as the version of WP e-Commerce that you’re using. I’ll then try and replicate this on my side.

    Regarding widget title, that’s something I have not thought of, and therefore not explicitly supported. There are 2 workarounds:
    1) CSS: if you are comfortable editing CSS, set display:none.
    2) Enter   as the widget title. When you save, it will look like the title disappears, in reality it is replaced with a single space. This should blank the title. Note that you have to enter the   exactly as shown here, and do not click save twice.
    I may provide a more elegant way of doing this in a future version.

    Thanks.
    Z

    Thanks for the workarounds on the widget title! To give a little more info on the product name disappearing act, I am using WP 3.1.3 and the plugin is 1.1.3

    Still no luck on my end… Here is an example of the HTML it outputs:

    <div id="pndl_featuredproductwidget-5" class="widget-header widget_pndl_featuredproductwidget">
      <h2>Featured Product</h2>
      <div class="item_image"><a href="http://dredgeandmine.localhost/products/grapple-rakes-accessories/66-heavy-duty-grapple-rake/"><img alt="" title="" src="http://dredgeandmine.localhost/wp-content/uploads/2011/04/66-Grapple-Rake-96x96.jpg"/></a></div>
      <div class="item_name"><a href="http://dredgeandmine.localhost/products/grapple-rakes-accessories/66-heavy-duty-grapple-rake/"><strong></strong></a></div>
    </div>

    Found it! Here’s a bug fix for your next release.

    File class-wp-e-commerce-access-v38 Line 12

    $product = array(‘name’=>$product->post_title, ‘description’=>$result->post_content, ‘id’=>$result->ID);

    should be

    $product = array(‘name’=>$result->post_title, ‘description’=>$result->post_content, ‘id’=>$result->ID);

    does that look right? At least it worked.

    I’d like to confirm this little missing bug. It had me confused for a while now. Thanks to karenalenore’s fix I got it sorted out.

    Thank you.

    Plugin Author zorgbargle

    @zorgbargle

    Hi,

    Thank you for the feedback, and for fixing the problem 😉

    I’ve made a release that also includes making the widget title optional (removing the need for the &nbsp; workaround I mentioned above)

    Please let me know either way if this fixes your issues.

    Cheers,
    Z

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Title Missing’ is closed to new replies.
Skip to toolbar