Support » Plugin: The SEO Framework - Extension Manager » Title Fix Plugin – Is not using the framework settings

  • Resolved unmus

    (@unmus)


    Dear.

    I have recognized that the title fix extension is not using the title settings from the SEO Framework. It seems that it is using standard settings.

    For example, I have configured in the SEO Framework that the title of a post is just the title without prefix or suffix. This is working. Sometimes wordpress does not output the title. In these cases the title of the posts are coming with “Title – Blogname”, which is the standard setting (if I remember right). My customiziation is not considered.

    Any possibilities that I can force this?

    Thank you very much in advance.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hi @unmus,

    It should use TSF’s title. If it doesn’t, then there are mixed signals coming from the theme, and the extension can stay dormant.

    To enforce the title fix, you can add this filter to your theme’s functions.php file:

    add_filter( 'the_seo_framework_force_title_fix', '__return_true' );
    

    If you’re not using the Incognito extension, then the title tag will have <!-- fixed --> next to it in the page’s source.

    Alternatively, you can modify your theme’s header.php file by removing the <title>...</title> output, and adding add_theme_support( 'title-tag' ); to your theme’s functions.php file.
    Then, you won’t need the Title Fix 🙂

    Hey Sybre.

    Thank you very much for the quick response. I think I have a missunderstanding regarding this Extension. I thought it solves the issue, if WordPress outputs its content without the title tag sometimes. But I have learned now, that it handles the Problem, if Themes are defining the title in the Header. Sorry for this making you unnecessary work!

    My theme is it doing correctly. The title tag is not included in the Header and functions.php includes add_theme_support(‘title-tag’).

    Nevertheless I have recognized that the title does not always match the configuration in the SEO framework. Currently I have no idea, how and why. I will keep monitoring this and open a new thread, if required.

    Thank you!

    Best Regards
    marco

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi @unmus,

    There’s a distinction between meta data and on-page data.

    TSF only touches meta data. This meta data helps crawlers and social websites understand what you try to convey with your pages.
    Visible on-page output data is not handled by TSF.

    If no manual SEO settings are set, TSF will automatically determine the metadata output.
    If manual SEO settings are set, they will be used instead of automatically generated data.

    If you’re speaking of the visible title not matching the SEO title you see in the browser-tab, then that may very well be true; depending on the settings used.

    I hope this clears things up! Cheers 🙂

    Kreativ LAb

    (@jabuddhikaperera)

    Hi Sybre,
    Will the code snippet above solve the issue I have with Homepage Title showing up as not intended on Google Search? I want the blog name at the end of the title. Eq: Bridal Salon | Beauty Salon | Salon Indumala. Please refer attachment https://pasteboard.co/GNuUx5X.png

    • This reply was modified 1 year, 11 months ago by  Kreativ LAb.
    Plugin Author Sybre Waaijer

    (@cybr)

    Hi, @jabuddhikaperera,

    The snippet above will force the title fix. Therefore, it’s most likely the title will be outputted as you’ve set it in the Homepage SEO settings meta box.

    Now, to test this, you should check out your page’s source.
    Within the <title>...</title> tag (high up in the page’s source) you should see what the title is. This is what Google will use.

    Kreativ LAb

    (@jabuddhikaperera)

    Hi Sybre,

    Thanks for the prompt reply! However I still can’t get google to show the proper Title of the Homepage on its Search Display. I have attached the source page for you to see. is it the theme thats doing it wrong? if so is there a way to force the titles? I want to get on the paid plan but this issue is holding me back as I have faced the same with the other 02 seo plugins.

    https://drive.google.com/a/qodelab.com/file/d/0Bwa4mAmrNw7uWUZyYWdpSHluYVU/view?usp=sharing

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi, @jabuddhikaperera,

    It can take up to three weeks before Google fetches the new title.
    The document you shared is behind a barrier. So, if you could share me your website’s URL that would be great! You can do that confidentially on my contact page.

    Cheers!

    Kreativ LAb

    (@jabuddhikaperera)

    The code has fixed the issue, Thanks ! You just earned a customer.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Title Fix Plugin – Is not using the framework settings’ is closed to new replies.