Support » Plugin: FancyBox for WordPress » Title disappeared for the gutenberg gallery option

  • Resolved cngcng

    (@cngcng)


    Hi,

    I have multiple galleries on the same page and I used data-fancybox=”gallery.1,2,3…” to define each gallery. The new “gutenberg gallery” option works like the old “Do not group images in gallery automatically” option except image titles are disappeared. If I choose the “gallery for all images” or “class=post” options the titles are displayed as usual. What can I do?

    I tried data-caption and title no difference.

    Thank you.
    C

    • This topic was modified 1 year, 1 month ago by cngcng.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The image title don’t pass to the HTML:

    For the default / class=post options:
    <div class=”fancybox-caption”><p class=”caption-title”>Ring & circle pattern (metallic)<span id=”image-no”>1 of 3</span></p></div>

    For the gutenberg gallery option it just emptied:
    <div class=”fancybox-caption”></div>

    Thanks!

    Plugin Support mplusb

    (@mplusb)

    Hello @cngcng,

    I am not sure I completely understood this so please bear with me.
    Could you please send me your website’s url so I can take a look and investigate?

    Thank you,
    Mihaela

    cngcng

    (@cngcng)

    Sorry for late reply. My website is http://www.plutolab.esy.es

    Plugin Support mplusb

    (@mplusb)

    thank you!
    Could you please change the class to fancyboxforwp ? And see if this fixes it?

    Thank you,
    Mihaela

    cngcng

    (@cngcng)

    Yes, the caption appears now, thank you. However pictures are not align to the middle vertically and the caption is right on top of them.

    I used below styles to control the caption and they worked for 3.2.0.

    .fancybox-custom-caption {
    text-align:left !important;
    padding-left: 15px !important;
    padding-bottom: 10px !important;
    font-size: 15px;
    background: #fff !important;
    bottom: -40px !important;
    }

    I can rollback to 3.2.0 to show the differences if you need.

    Thank you,
    C

    Plugin Support mplusb

    (@mplusb)

    Hello @cngcng,

    Please go to your dashboard > Settings > Fancybox for WP > Misc > and check ‘Dimensions’ then save. This should solve the issue with the alignment.

    cngcng

    (@cngcng)

    It works perfect now! Thank you for the help 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Title disappeared for the gutenberg gallery option’ is closed to new replies.