Support » Fixing WordPress » Title, Description & Keywords Problem

Viewing 2 replies - 1 through 2 (of 2 total)
  • Christine Rondeau


    Volunteer Forum Moderator

    It looks like you have the all in one seo plugin installed. To change the meta info for the home page, you’ll need to go under settings > All in one seo.

    All other pages can be edited by going to the individual pages, but make sure that the all in one seo is selected under screen options.

    I wrote what I wanted as title, description & keywords in ‘all-in-one SEO’ but my blog is automatically showing what is in my general setting. Instead of a good description, ‘Welcome!’ is showing after my title in browsers. What should I do?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Title, Description & Keywords Problem’ is closed to new replies.