Support » Fixing WordPress » TinyMCE wipes away tags and puts p and br.

  • Some times ago I correctly made some posts on my blog featuring <blockquote>, <ol> and other pretty tags in a way that the w3c validator apreciated very much.

    Today I needed to edit that post and when I clicked “Save”, all the fancy things suddently disappeared and were replaced by and .

    I read around that this must be a TinyMCE problem but I can’t figure out why this bug have appeared just today. After discovering this bad thing, I upgraded my WP from 2.0.3 to 2.0.4 but nothing got better.

    Ideas?

    PS: No, switching to the standard editor doesn’t seem to work. I’ve already cleaned my firefox cache, reloaded the browser, tried M$IE…

Viewing 4 replies - 1 through 4 (of 4 total)
  • I use the standard editor and it keeps my markup just fine. What other plugins do you have activated? Any admin plugins? And are you sure this happened just for this one post? When you go back to edit other posts, the markup is left alone? When you view other posts through your blog (not the admin side), is that markup there on some older entries you thought you’d cleaned up?

    No plugin is active. This happens also on old posts but just when I go and just “save and continue” or “save” them. The markup remains unaltered until I go through admin controls to edit and save the post. Any other markup tag than p or br is cleaned (eg: img, blockquote, ol…).

    For now, I’m working with an offline client but my other users are pretty upset by this.

    In addition: I must say this is not happening in other wordpress blogs (ie: trial blogs, my local install…)

    I forgot to mention that I’m running on PHP Version 5.1.4-pl4-gentoo with Hardening-Patch 0.4.11 and talking with my host it seems that the bug is related to the policies of php 5.1 hardened and this will become the default policy from 5.2.x on.

    He told me to translate the html entities that the form sends with a particular php function but he can’t remember which one.

    May I put a remark on http://trac.wordpress.org/ticket/1696 ?

    I noticed that that bug wasn’t the one I discovered, so I opened a new ticket: http://trac.wordpress.org/ticket/3043

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘TinyMCE wipes away tags and puts p and br.’ is closed to new replies.