Support » Plugin: NinjaFirewall (WP Edition) - Advanced Security Plugin and Firewall » TinyMCE problem is back — post won't show for authors

  • “NinjaFirewall will not block access to the TinyMCE WYSIWYG editor even if this option is enabled.”

    This was true for a while, but I just verified that TinyMCE doesn’t work correctly (except for administrator) unless I have access to the php files in that option enabled (1 Oct 2015).

    Apparently, a recent update brought back the bug. I would like for my guest authors to be able to use TinyMCE. Or, if there is another post editor that works around this problem, I could install that.

    https://wordpress.org/plugins/ninjafirewall/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nintechnet

    (@nintechnet)

    Hi,

    I cannot reproduce this error. If I log in as an author, I can use the editor.
    Can you try again and, as soon as you are blocked, check the firewall log and post here the corresponding line?

    Thread Starter Howard Harkness

    (@chltx)

    Turned out that I had missed a setting. I fixed the problem by going back to a site that was working properly, and carefully copying each setting.

    Ninja Firewall WP is a great product, but the setup is pretty daunting — way too many “moving parts.”

    You would do well to create some simplified setting clusters — or, organize the settings into groups with more detailed explanations for the consequences of setting or unsetting.

    Plugin Author nintechnet

    (@nintechnet)

    carefully copying each setting

    You can easily export the configuration from one site and import it to another from the “Firewall Options > Export configuration” menu, as long as both sites use the same version of NinjaFirewall.

    Thread Starter Howard Harkness

    (@chltx)

    Thanks for the tip!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘TinyMCE problem is back — post won't show for authors’ is closed to new replies.