WordPress.org

Forums

TinyMCE Advanced
TinyMCE not working with latest wordpress version (13 posts)

  1. nguyenbaodanh
    Member
    Posted 10 months ago #

    I've installed TinyMCE but since the last update it stop working on my wordpress ... now WP show up the default editor buttons.

    http://www.minhthanh.com <-- my site

    Since I'm new to wordpress I don't know how to gather more information to post :(

    Need help.

    https://wordpress.org/plugins/tinymce-advanced/

  2. Julie Ealy
    Member
    Posted 10 months ago #

    Neither can I see the TinyMCE Advanced toolbar on the Write page in dashboard. The basics are there (words not icons), such as Source. So I know something is going on. But can't do anything. Have Genesis Prose child theme. Don't know if that matters. It is very distressing. I have spent the past 6 hours straight implementing all the suggestions on all the forums and nothing works.

  3. nguyenbaodanh
    Member
    Posted 10 months ago #

    :(
    I really need this plugin to work on my site

  4. Julie Ealy
    Member
    Posted 10 months ago #

    Well, I am eating crow now...but happily. I did have the text toolbar (i.e, "Souce,"Insert,") for TinyMCE but could not find the icon toobar with all the functions, which I had customized (Dashboard Settings⇢TinyMCE). Then after six hours of strife, I saw an icon on the WordPress Toolbar that said "Toggle" (toggle something). I hit it and the TinyMCE toolbar appeared! I almost started crying. I am posting my folly just in case anyone else is another blind mice...there it is. (Please post a response if so.)

  5. Julie Ealy
    Member
    Posted 10 months ago #

    Well, I am eating crow now...but happily. I did have the text toolbar (i.e, "Souce,"Insert,") for TinyMCE but could not find the icon toobar with all the functions, which I had customized (Dashboard Settings⇢TinyMCE). Then after six hours of strife, I saw an icon on the WordPress Toolbar that said "Toggle" (toggle something). I hit it and the TinyMCE toolbar appeared! I almost started crying. I am posting my folly just in case anyone else is another blind mice...there it is. (Please post a response if so.)

  6. nguyenbaodanh
    Member
    Posted 10 months ago #

    "Toggle" ?

    can you make a screenshot ? I can't see it anywhere >.<

  7. nguyenbaodanh
    Member
    Posted 10 months ago #

  8. Julie Ealy
    Member
    Posted 10 months ago #

    You need to switch from Text to Visual on the tab to the far right first. Then hold your curser over a square box that looks like it has a grid on it. Best I can describe. It will say "Toggle Toolbar." If you have uploaded Tiny MCE correctly it will flip down. I am assuming you have gone into Settings on your Dashboard. Then gone to TinyMCE Advanced in the dropdown. That takes you to Editor Settings in Tiny MCE where you drag the functions you need onto the toolbar. Also make sure you check Load CSS style sheets or something like that.

    I am including a screenshot. The Toggle Toolbar is in the top row on the end. Make sure you are in Visual and not Text.

    http://screencast.com/t/7RrwIstcGMmn

  9. nguyenbaodanh
    Member
    Posted 10 months ago #

    and this is my screen when I switch to Visual

    http://i.imgur.com/StnTKxC.jpg

    No buttons...

  10. Julie Ealy
    Member
    Posted 10 months ago #

    You are in your Dashboard "Add New Page."

    Did you download TinyMCE from WordPress? And save it to your Desktop or someplace on your computer where you can find it?

    Then did you go to Plugins in your WordPress Dashboard and click "Add New"?

    Once you were there, in "Install Plugins" did you click on "Upload" in blue at the top?

    Then did you click on the "Browse" button? Which takes you to your computer files. And then click on TinyMCE where you saved it on your computer? And hit a blue button on your computer that says "select" or something like that.

    If you did all that, then you can continue with my other instructions about going to "Settings" on your WordPress Dashboard, click on TinyMCE, which should be there in the sub menus now. This takes you to Editor Settings. In Editor Settings, drag the TinyMCE icon buttons you want into the (blank) toolbar space above. Make sure to check the "Load CSS" box. Return to your New Page, and toggle the toolbar, last icon button on the end, top row. The TinyMCE toolbar you just created should drop down if it is not there already.

  11. nguyenbaodanh
    Member
    Posted 10 months ago #

    Tried all ... no help.

    I'm asking template maker for support now . I'm using "WPBakery Visual Composer" plugin ... I think it may cause this problem

    Thanks Julie :D

  12. BillyInHudsonFl
    Member
    Posted 9 months ago #

    I had the same problem, No font size or type. I uninstalled the TinyMCE Advanced plugin then clicked on "Plugins add new" and typed TinyMCE to try and install it again, i noticed the one i uninstalled but below that was "TinyMCE and TinyMCE Advanced Professional Formats and Styles" I installed that and now have the font size and type back..

  13. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 7 months ago #

    Well, you can customize the editor toolbars after installing TinyMCE Advanced. This is quite a big part of this plugin :)

    More details: http://www.laptoptips.ca/projects/tinymce-advanced/#enable-buttons

Reply

You must log in to post.

About this Plugin

  • TinyMCE Advanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.