WordPress.org

Forums

[resolved] TinyMCE not appearing when wp_editor is called (WP 3.9) (4 posts)

  1. Christiaan Conover
    Member
    Posted 1 year ago #

    One of the features of my plugin is to add a TinyMCE editor instance inside a meta box on the Edit Post screen. This has worked great up until 3.9, and I'm not clear as to what's going wrong.

    Here are the relevant files containing the code for the meta box editor (links to files inside Github commit):

    admin/author-customization-admin.php
    admin/assets/js/edit-post.js

    What am I missing? This is what I'm given when I load the Edit Post screen:
    http://i.imgur.com/6GQUUa9.png

    The contents are there though, which you can see when you highlight inside the textarea:
    http://i.imgur.com/jTSlgWm.png

    On WordPress 3.8.1 the code works just fine:
    http://i.imgur.com/i7nTqPb.png

    I'm not sure whether it's an issue with the PHP code or the JavaScript. Any help is appreciated.

  2. Christiaan Conover
    Member
    Posted 1 year ago #

    This has been solved: the problem related to using brackets in the editor ID, which TinyMCE does not support. You can find more details in this Trac ticket.

  3. Yakir Sitbon
    Member
    Posted 11 months ago #

    I haven't brackets in the editor ID, and I still get this error. What's the problem?

  4. Christiaan Conover
    Member
    Posted 11 months ago #

    Yakir,

    Please start your own thread, per the forum rules.

Topic Closed

This topic has been closed to new replies.

About this Topic