Support » Fixing WordPress » tinyMCE is not defined!

  • Hi my WYSIWYG dont work and i get this message from Firebug when i press the html button in WYSIWYG:

    tinyMCE is not defined
    var ed = tinyMCE.get(id);
    editor.j…=20080325 (line 82)

    I have done everything on this form
    Forms and more but nothing works

Viewing 9 replies - 1 through 9 (of 9 total)
  • There seem to be MANY possible causes for this problem — JSCache, the WPLANG setting in wp-config, compression settings, BSD operating system glitch, etc. etc.

    After a day and a half of trying to figure it out, I finally located my particular issue — IT administrator had placed a .htaccess file in the wp-includes folder, which seemed to prevent WP from accessing TinyMCE. Deleted the file and we’re up and running again.

    Just thought I’d put this one out there in case anyone else has the same issue.

    You seem rather competent with the vanishing visual editor … Maybe you could help me. I tried (on 2.5.1 and 2.6, same database) : js cache and compressing settings (disabled with “testing tinyMce plugin), wplang set to “en”, changing theme, no htaccess … But i had no success finding my particular issue … Could you tell me more (or pointing a thread related to it) about “bsd operating system glitch” ? Thanks.

    @ouranos2, there are few threads with possible fixes. What do you see when going to TinyMCE’s script directly as described here, step 4:

    Thanks. I read this thread a few days ago but nothing worked. Though, i think i’ve found my particular way of vanishing …
    Two errors in my case in Firefox console :
    – The famous “cannot modify header information” (See all message further)
    – tinymce is not defined.

    I remembered somebody talking about a problem with wp-config.php. I had modified my wp-config by editing it directly with Filezilla FTP client and figured it could be the problem. So I’ve reloaded a fresh wp-config modified and registered locally. And … it worked … Hope it can be of any help for some sad “vanished” … (Sorry for my poor english)

    Error : invalid flag after regular expression Fichier Source : tiny_mce_config.php?ver=20080711
    Ligne : 2, Colonne : 11
    Code Source : <b>Warning</b>: Cannot modify header information – headers already sent by (output started at /home/www/remigros/www/wp-config.php:1) in <b>/home/www/remigros/www/wp-includes/js/tinymce/tiny_mce_config.php</b> on line <b>243</b>

    Wow, thanks ouranos2! Your wp-config solution fixed it. Such a simple fix. I wouldn’t have ever thought of that in a million years … I swear I’ve re-uploaded my wp-includes folder 100 billion times lol.

    I solve the problem changing wp-config.php encoding from utf-8 to ansi

    ouranos2 – your suggestion has worked for me too! I had the same problem as many others on many forums, yet none of the other fixes worked. I had been using a copy of my wp-config.php carried over from many versions of WP ago and upon examination there have been changes in the file! I simply put in my DB info in the latest wp-config file, uploaded, and it worked. Very happy!

    I have disabled all plug in and after removed cache browser tinyMCE work. Than i have abilited one plug-in time and revoce cache and i have discovered that th problem on my blog i causated with :

    Post Thumb Revisited plug in

    Thank you, ravirajakumar! I deleted that .htaccess, and the toolbars in both the HTML and visual editors reappeared. Since there’s already an .htaccess in the main wpmu folder, it doesn’t seem necessary to have that other one.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘tinyMCE is not defined!’ is closed to new replies.