[resolved] TinyMCE image uploading (22 posts)

  1. dvmorris
    Posted 9 years ago #

    I'm not sure which part of this is a plugin and which is just included in wordpress, but anyways, here goes:

    I am trying to upload images and place them in a page using the image upload tool, and it places the images much smaller than the actual size.

    Is there a way to get it to automatically drop the images in at the full size? without using the resize handles and trying to guess?

  2. Kafkaesqui

    Posted 9 years ago #

    If you toggle the "Using Thumbnail" setting to "Using Original" and then send the image to the editor, does this not work?

  3. moshu
    Posted 9 years ago #

    No, it puts there the image in its original file size but still only thumbsize (pixel-wise:).
    One has to click the image in the text area and drag the corners to get a "normal" size.

  4. Kafkaesqui

    Posted 9 years ago #

    If I upload a file, click "Using Thumbnail" to toggle to "Using Original" and select "Send to editor," it keeps the original size of the image. At least it does *for me.*

    Only if I drag it to the editor form does it turn into a thumbnail image.

  5. moshu
    Posted 9 years ago #

    KafkaesquĆ­, are you sure you are using a vanilla 2.0?

  6. Kafkaesqui

    Posted 9 years ago #

    I'm not, which is why I'm asking what everyone else is doing. I'm trying to verify if this is a common problem resolved in the bug fix version (coming soon).

    Sorry I wasn't clear about that*.

    * Actually, I didn't seem to note this at all. Goofy me.

  7. moshu
    Posted 9 years ago #

    Upload, click > toggle: Using Original; Send to editor ==> a 100 KB file reduced to 128x83px.

  8. dvmorris
    Posted 9 years ago #

    yes, i agree, no matter what i do i seem to have to use the resize handles. is there a better wysiwyg editor out there for wp? one that has tables and more stuff like that ?

  9. jaybarrow
    Posted 9 years ago #

    Same issue here. No matter which I choose, I get the same code. I'm not dragging anything anywhere.

    If I choose "Using Original" and then "Send to editor", the code inserted is for a smaller size, not original size.

    If I choose "Using Thumbnail" the code is the exact same. The image specified is not for the thumbnail version. If I delete the width/height attributes of the inserted code I see the original (large) image size without distortion/pixellation.

    There are 2 versions of the image created in my uploads directory: image.jpg, and image.thumbnail.jpg. No matter what combination I use, I generate no "thumbnail" code. Yet the dimensions would specify otherwise.

    I get the same results regardless of OS/Browser. Is this a glitch in WP 2.0? Tell me which file to hack and I'll fix it myself.

  10. jaybarrow
    Posted 9 years ago #

  11. dvmorris
    Posted 9 years ago #

    thank you.

  12. eyerouge
    Posted 9 years ago #

    This is solved in the coming 2.0.1 version of WP.

    See >>


  13. gendem
    Posted 9 years ago #

    Well, I'm using 2.0.1 and it's still putting in the wrong dimention attributes.


  14. jaybarrow
    Posted 9 years ago #

    Yup. I just upgraded to the 2.0.1 thinking this would be fixed. It ain't. At least the code inserted is correct, it's just missing it's height/width attributes.

  15. lozbrown
    Posted 9 years ago #

    Hi I downloaded the new inline-uploading.php from here:


    But it still puts the height attribute in? I really dont understand what I am doing wrong.

    I am using wordpress 2.0.4

  16. talgalili
    Posted 9 years ago #

    how about just using the ImageManager plugin ?

  17. bobmorris60
    Posted 9 years ago #

    I never get the full-sized image, so I Edit HTML, take out the width and size, and the ".thumbnail" get the image is then full-sized.

    Sounds complicated, takes about five seconds.

  18. Chris_K
    Posted 9 years ago #

    @bobmorris60 - after you upload the image, click it. Regular ol' left click.

    You'll get a menu with all sorts of neat options, including the ability to toggle thumbnail on and off.

  19. glmjjb
    Posted 9 years ago #

    Hi Handysolo, I've left-click on the image, and whatever I choose Using Original or Thumbnail.... it do post the O'image or T'image at Thumbnail *display size*.

    I am using WP 2.0.4.

    I just found that this problem only appears in IE (IE6 SP2).

    But it works fine at my Firefox

  20. PetLvr
    Posted 9 years ago #

    This same thing is happening to me, and it's not an IE vs FF issue - it's adding "height=96" to every image.jpg that's selected at original size. If I select the thumbnail, that separate image.thumbnail.jpg is used instead. I'm using 2.0.4 and it's frustrating.

    Does anybody know a way (or where in the code or in a plugin) to change this "height=96" embed to a "width=400" embed instead?

    HART aka PetLvr

  21. mbc
    Posted 9 years ago #

    I'm adding my post to this thread..a I've received no answers in my own thread. Not sure if it's the way I worded my post..the heading or if it's in the wrong place. I thought it belonged under 'Plugins and Hacks'..but maybe not. If not my apologies.

    I'm having the same problem in both IE and Opera..at one time it worked fine..now I only get thumbnails if that.
    Original post:

    Still having issues with my image manager. I'm using the Opera browser,and cannot see any of the icons that are usually above where I write my posts..they used to be there..so am not sure why they aren't any longer. I do however 'sometimes' see them in IE...sometimes not.

    In IE when the icons are working..I click on the image manager icon (above posts and the 'insert image' window opens up..but when I choose an image..the file will not open in the directory path..instead insert image window.here is a 'Error on page' message at the bottom of the insert image' page.

    Now that is the problem when I access image manager from the icons 'above' the box where I'd write my posts.

    Underneath the write posts box..there is a place where image manager can also be used to browse and upload images. There are no icons there either (in truth I can't recall if there ever was but I 'think' there were icons. I do see the upload/browse buttoms. If I click browse..monthly folders appear with my old uploads. But in the background..behind the folders I get this error message

    "Fatal error: Call to undefined function: () in /home/heroindi/public_html/maryblackchurch/wp-content/plugins/stattraq.php on line 90"

    For now I've deactivated 'StatTraq' but it changes nothing...image manager still isn't working properly.
    If I click on an image and choose 'send to editor an error window opens and says 'an editor instance must be focused before using this command.' I cannot get any images inside a post.

    Under options/image manager/path/bas mage directory: it reads:

    should I change it to something else?

    I read the suggested link from Yosemite about the 'line 90' error..but still cannot figure out what to do about this..any help would be much appreciated.

    Is there a simpler image plug-in I can use for now in place of imagemanager?

    Thanks much

    original thread link:

  22. mbc
    Posted 9 years ago #

    I decided to try and upload a new copy of the Wysiwyg plug-in and deleted the old one from my plug-in folder.

    Some SUCCESS..most of my icons above where I write posts are showing again in both IE & Opera..the only ones not showing with an icon picture are the 'bold, italic and underline' ones. I see the boxes but no picture.

    Any ideas how I can get them to show again?

    Am seeing all the window for image manager & options now as well. Still having diffiuvlty actually implementing images in my posts though.

Topic Closed

This topic has been closed to new replies.

About this Topic