[resolved] tinyMCE - How to disable wpeditimage? (3 posts)

  1. Hansaplastique
    Posted 3 years ago #

    I'm using wp-editor() to call tinyMCE for comments.
    I have stripped it down by removing buttons, HTML tab, etc etc.
    So far it works great although it took me some toying around to move tinyMCE in the DOM, but that even works great now.

    The only problem I have is that I want to prevent wpeditimage to popup (with an edit and delete button - just the delete button wouldn't be bad!) when a user clicks and image.
    Seeing the popup with advanced settings for the image is something I really would not like to see happening in the comments form.

    Any suggestions on how to prevent this ..?

  2. Hansaplastique
    Posted 3 years ago #

    Never mind ... figured it out ... :-)

    function tinymce_remove_stuff( $config )
    		$config['plugins'] = 'inlinepopups, fullscreen, wordpress, wplink, wpdialogs';
    		return $config;
    add_filter('tiny_mce_before_init', 'tinymce_remove_stuff');
  3. Hansaplastique
    Posted 3 years ago #

    This solved the problem - just forgot to check the "mark this topic as resolved".

    p.s. this code of course goes in the functions.php.

Topic Closed

This topic has been closed to new replies.

About this Topic