Support » Plugins and Hacks » TinyMCE editor not loading after installing plugin

TinyMCE editor not loading after installing plugin

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author akarmenia


    I suspect the older version of WordPress is the reason. Can you update to 3.5? I’ll investigate the issue in any case.

    To be honest, that was also my first idea, sadly at the moment I can’t invest the time to update the site, since it would not be just a simple pure update, some of crucial ‘look and feel’ plugins are not compatible with latest WordPress version. But it seems I’m just delaying the inevitable. Thx!

    I’m having the same problem. With the TinyMCE enabled in bbPress, and with Crayon installed, the Visual editor loses the toolbar entirely and loads existing text as white. The Text editor continues to work, and shows the Crayon button.

    WP3.5.1, bbPress 2.3, Crayon 2.2.0.

    http://powershell.org/wp/forums – you’ll need to create an account, and note that the menu bar FORUMS item doesn’t go to that spot yet. You’ll need to use that URL.

    Any suggestions?

    Follow-up: I’m incorrect; it isn’t loading the TinyMCE with white text. It doesn’t appear to be loading TinyMCE at all. I get the Text editor, but nothing in the Visual tab – can’t even type. The HTML is definitely in the source – I can see all the buttons’ <input> tags – but nothing is rendering.

    On loading the page. tinymce_register.js is spewing “Can’t find variable v48fv.”

    I also got a failed to load resource from tiny_mce.js, attempting to load /crayon-syntax-highlighter/util/tag-editor/langs/en.js.

    And finally, a “refused to display document because of display forbidden by X-Frame-Options,” /crayon-syntax-highlighter/langs/en.js.

    Hmm. You know, we use MaxCDN and CloudFlare. I’m strongly wondering if that has something to do with this, because it sees your script coming from a different URL. Let me investigate a bit – in the meantime, any suggestions appreciated.

    Yeah, confirmed. It’s the CDN. I just need to figure out how to stop your code from being rewritten to the CDN URLs. This is something you’ll probably want to document or FAQ, if you’re not able to create a workaround for it.

    As a further note: Using W3 Total Cache plugin, you will have a default “wp-content/plugins/*.js” item int he Custom Files List under the CDN configuration. This cases all plugin JS files to be rewritten to the CDN. If you add “wp-content/plugins/crayon-syntax-highlighter/*” to the Rejected Files list, the JS files will STILL be rewritten to the CDN. I was able to make this work by removing “wp-content/plugins/*.js” from the Custom Files List. I realize this means many of my other plugin JS files are no longer in the CDN, but this seems like the only short-term workaround.

    Plugin Author akarmenia


    W3 Total Cache plugin shouldn’t be required anymore, the resources are minified now. I’ve updated the docs to reflect it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘TinyMCE editor not loading after installing plugin’ is closed to new replies.