Support » Plugin: HW Image Widget » TinyMCE Does Not Initiate Either

  • Resolved crotin


    no way i can write some simple into that box!

    i unstalled hw image plugin, deleted it, dowloaded and installled a fresh version, shut down my wordpress admin panel for 12 hours but the situation remains the same.

    note: i must say though everything went fine the first time i tried to enter some text 2 days ago. problem appeared after that.

    it’a real pity since i’d like very much this plugin and would be prepared to pay for it provided that it works.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Håkan Wennerberg


    Please try inactivating all plug-ins except, the image widget and see if it works then.

    If it has worked at least once, its not subject to change unless the surrounding environment has changed. Perhaps some new plug-in, or theme?

    thanks Hakan for your reply.

    i was preparing to deactivate a couple of plugins I had installed since HW Image stopped working. But before that, i decided to give HW Image another go: it works perfectly!

    What’s more, 12 hours ago (from now), i had tried AGAIN to enter text but no success.

    So, with all the respect for your great work (HW Image is, as far as i know, the ONLY RESPONSIVE plugin of the kind), should i conclude that HW Image behavior is somewhat unstable?

    Please let me know what you think. (if you need more information about my setup – server, plugins, theme – please let me know and i’ll send you a private message wherever you want. Thanks again.

    Plugin Author Håkan Wennerberg


    I would not consider it unstable since I have no confirmed bugs at the moment.

    Its hard to try fault finding issues without having a replica of the environment. But I am still pretty sure it has something to do with conflicts of other plugins/widgets.

    When the TinyMCE editor won’t show, are there any errors in the web browsers developer console?

    I understand.

    Maybe some conflict, but how can I know. The plugins are used are very highly rated and most of them endorsed by the Genesis Framework developers.
    What’s more, I don’t use many plugins.

    To answer your question, I didn’t check the browser’s developer console when I had all my problems. The only thing I know is that it becomes just impossible to type anything into the TinyMCE, into the text area. It seems blocked and doesn’t react.

    Plugin Author Håkan Wennerberg


    It does not have to be a “bad” plugin, just a plugin that might cause conflicts; using the same JS components, listening to the same events and so on. It might just as well be some bug in the HW Image Widget that is causing conflicts.

    Anyway, I am currently developing the 2.0 version of this widget, incorporating the new Media Library and rewriting the JavaScript to be a little less likely to be part of conflicts. I hope that will resolve the problems you have been experiencing.

    yes, i’m not sure, i’m not a developer 😉

    thanks anyway for your answers and for keeping the excellent work.
    once again, to my humble opinion, your plugin is just GREAT!

    Plugin Author Håkan Wennerberg


    Just released version 2.0. Let me know if it works better.

    Thanks very much Hakan.

    Unfortunately, i encounter the same problem…

    I removed the existing HW Image widget i had installed and tried to create it again but impossible to type in the “text” area.

    Sorry for the bad news.

    Hi Hakan,

    This plugin seems great, but I am having the same problem, and then some:

    The TinyMCE editor does not load so i cannot enter any text, is there a way for me to disable it completely and just enter plain text.

    I have also tried disabling all other plugins, but no success. In fact when I disabled the previous image widget i was using while keeping the HW Image widget enabled the widget screen stopped working as expected. The dropdowns on the right side of the widget config screen would not work anymore.

    I am using wordpress 3.5.1 running on a Linux Mint 13 server with Apache as the web server. I am also using version 2.0 of the image plugin.


    Plugin Author Håkan Wennerberg


    If the widget area folding does not work at all, there is some sort of JS issue on the page.

    What themes are you using? Anything I could download check?

    On the widget page, when its not working, are there any errors in the console (F12)?

    I am using responsive with a child theme to allow an extra bottom widget on the home page.

    the only error in the console is:

    init back-end.js:168
    Uncaught ReferenceError: wp is not defined back-end.js:177

    The error only appears when plugin HW Image Widget is ENABLED and Image Widget is DISABLED

    Plugin Author Håkan Wennerberg


    I was finally able to replicate the error. I updated to version 2.1, please check it out and let me know if it resolves the issue.

    Hi Hakan,

    The issue with the folding is now resolved, but the text area still remains unusable

    Plugin Author Håkan Wennerberg


    Try opening an browser “Icognito/Private” Window, login to WP and see if the editior initializes using that. This way we can ensure no cookies concerning the editor has been set in that window.

    What browser are you using?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘TinyMCE Does Not Initiate Either’ is closed to new replies.