Support » Fixing WordPress » TinyMCE do not show up in WP 4.8.2

  • Resolved kaarlo

    (@kaarlo)


    I have recently made two different WP-installs of 4.8.2. In both the TinyMCE-menu are deleted. They are just plain installs the WP-way with DB-info added. When I check the preinstalled theme in the panel, TinyMCE-menus are gone, both in Posta and Pages.
    The server has PHP 5.6.21
    Javascript is enabled in the browser.
    Just now now domains are activated.
    No new themes or plugins are added.

    I can´t figure out what has gone wrong. Do you have any idea?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Seventeen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    James,
    I appreciate your comment. In fact, I have not yet loaded any plugins. So, in that case, the install is clean.

    As you suggested I also tried different themes, Twenty Fifteen, Twenty Sixteen and Twenty Seventeen. But that did not change the appearance of TinyMCE.

    I know there are other TinyMCE-plugins. But my feeling is that if the groundwork of the site does not work properly, how can I trust any additions?

    As I met this on two different installs, I expect not to be alone in this experience. Might it be that there is a newer version of TinyMCE? Where might that version then reside and how do I update it? Does anyone know?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    If TinyMCE itself was broken in WordPress 4.8, we’d have a few million reports of it: https://wordpress.org/download/counter/

    This is the first report I’ve seen described as such, which leads me to still suspect a problem on your end, so let’s focus on something different.

    First, please make sure that your browser is up to date by visiting https://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    Thanks, James! You said: “If TinyMCE itself was broken in WordPress 4.8, we’d have a few million reports of it:”
    Yes, I fully agree. As I could not find anything in my searches I began reflecting on my download. I remembered that I had installed a Swedish version from the Swedish wordpress.org, so I began to wonder if the English version might be different.

    However, I first made a check of my browsers, as you suggested:
    Firefox 57 Developer Edition
    Chrome 61
    Edge 15
    And yes I checked cache and cookies as well as browser extensions.

    First, I tried the existing install after my browser checkup. But no changes to TinyMCE.

    After that, I reinstalled WP from the original English site (wordpress.org) but I kept the database. But no changes after that either.

    Then I began to consider if the database could be the problem. So I created a completely new database, and I had to make still another reinstall of WP (English version). But TinyMCE did not show up after these changes. Not in any of the three browsers.
    I tested Opera 47 as well, but that did not change anything.

    If I can´t solve this before Monday I will speak with my web host. They are rather good on WordPress.

    Well, now I am even more confused about what may cause this error.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Thanks for confirming!

    Would you please check for any reported JavaScript errors next? https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    James,
    Thank you for your endurance. I appreciate your help.

    I checked some older sites I have produced and found that TinyMCE worked as expected there with WP 4.8.2. So they behaved just fine. Therefore I plan to install WP with an older version in order to check if it will work with TinyMCE after an update to current version.

    OK, then I checked for JavaScript error as you suggested and yes there are errors. I got the following message in Chrome:

    JQMIGRATE: Migrate is installed, version 1.4.1
    wp-tinymce.php Failed to load resource: net::ERR_CONTENT_DECODING_FAILED
    post.php?post=2&action=edit:1861 Uncaught ReferenceError: tinymce is not defined
    at post.php?post=2&action=edit:1861

    So now it is confirmed that there is an error in the script for TinyMCE. I checked the line 1861 but I do not have a clue what to change there.

    In Firefox I got the following message (freely translated to English):
    Loading failed for <script> at source: …../wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4603-20170530”.

    FF said directly: ReferenceError: tinymce is not defined post.php:1861:1

    As I am not a PHP-guy I think I have to find some other way to solve this. Maybe that could be installing a former version of WP.

    So, now I have a proof but no medicine.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    It may be less of an error, and more like JS running into a process limit before it reaches that point.

    Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    To do so, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and edit the file with a plain text editor.

    https://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

    James, thank you, soo much!

    I am impressed. Great advice as it works. I added the line with the help of NotePad++ and FileZilla. Directly after refreshing the browser TinyMCE did show up. What a relief I feel.

    I am very grateful for your patience with this very disturbing issue.
    As I had the same problem on two different websites you doubled up
    my happy feelings.

    I am very pleased with your kind support.

    Best Regards,
    kaarlo

    Check to see if you have some .htaccess files inside your wp-includes folder! I was having this issue and it seems that it was caused by a .htaccess file in the root of wp-includes!

    Thank you webmakers2011,
    I will also look for that .htaccess next time.

    Last time (it has happened many times) I installed a new site, I just did a new reinstall of WP in the back-end update panel. That solved the problem.

    I have noticed that when I move the files with FileZilla to the web server I often get messages that the installtion will overwrite something even if the site is totally clean. Usually, I accept FileZilla to go on in writing my files to the server. Could maybe that cause this error with TinyMCE not showing up?

    • This reply was modified 2 months, 3 weeks ago by  kaarlo.
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.