WordPress.org

Support

Support » How-To and Troubleshooting » TinyMCE broken after WP 3.5 upgrade

TinyMCE broken after WP 3.5 upgrade

  • Following the WP 3.5 upgrade to one of my sites, I have had to install CKEDITOR to get proper editing of posts. TinyMCE and Ultimate TinyMCE (which I was using) just don’t work any more. Inserting links does nothing, can’t switch to HTML view, lots of other issues. Removed the “ultimate” plugin and deleted it, but the standard editor has the same issues. Switched to CKEDITOR (which I hate with a passion) and everything works again.

    I believe this issue may somehow be related to the use of custom fields and/or custom post types. The editor works ok on my other upgraded sites, just not on the one using custom fields and custom post types in the theme (GeoTheme). There was a similar issue earlier this year with ACF (which I don’t use).

    Gonna have to downgrade at this stage, which is a shame.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same problem here with both TinyMCE and TinyMCE advanced. I don’t think it has to do with custom fields, which I use on several WP sites. TinyMCE A works on some, doesn’t work on others.
    Deactivating the TinyMCA Advanced plugin doesn’t help – as described by websupportguy.
    My guess: a conflict with one of the other plugins I use or maybe some glitch in the German language version of WP 3.5 (though I rather think not).
    Any help is very much appreciated!

    I’m not quite sure yet, but after deactivating the Installer plugin (by OnTheGoSytems Inc, v 0.4.2) TinyMCE Advanced seems to be working again. There’s a newer version of this plugin (used to install plugins and themes from commercial repositories, like WPML) – 0.4.3.1 – and I hope that it will not break the editor (again?).

    Josh

    @josh401

    Moderator and Editor Customizer

    Ultimate Tinymce developer here. It should work fine with the new version of WP. I’ve tested it across multiple platforms.. and maintain a forum where other users have posted their miscellaneous fixes.
    http://forum.joshlobe.com

    Let me know if I can be of any help with the Ultimate Tinymce plugin.

    Update: installed and activated the Installer plugin 0.4.3.1. TinyMCE Advanced still working 😉

    I don’t get it, what you did to fix this? I am having tons of problems.

    I use the Installer plugin (by OnTheGoSystems) on my multilinugal WordPress sites (with WPML). I had the version 0.4.2 installed which seems to have caused _my_ problems. I updated the Installer plugin to version 0.4.3.1 and everything was okay afterwards.
    Not sure if it will help with _your_ tons of problems, though.

    🙂 Ive just installed that plugin and removed Tiny MCE advance, but same as before. When I am adding link to some text, it won’t save and it is adding some empty spaces between parts of posts.

    I tried disabling all plugins on my site and still had all the same problems with both TinyMCE and TinyMCE advanced. If I switch to Twenty Eleven theme, it works. If I switch to CKeditor, that works. But neither of these are solutions as I have a site based on a premium theme.

    Josh, any suggestions about where to look? Is this related to the issue earlier this year with ACM and advanced custom fields?

    @josh, tried the suggestions on your site (cleared browser cache and cleared jwl_ option entries, but did not fix it. I am seeing the following errors in the browser:

    Message: Object doesn't support this property or method
    Line: 24
    Char: 471
    Code: 0
    URI: http: //[myurl].com/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=358-23156
    Josh

    @josh401

    Moderator and Editor Customizer

    That is a default WP file.

    Try grabbing a fresh copy of WP 3.5 and replace your “wp-includes” folder from the fresh copy.

    I doubt this has to do with custom fields or custom post types. I’ve upgraded to 3.5 on several sites with both, and not experienced a problem with Tiny MCE.

    Does your premium theme modify the editor in any way; perhaps creating a custom style sheet for the editor?

    Theme vendor issued an update which fixes it. But thanks for your help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘TinyMCE broken after WP 3.5 upgrade’ is closed to new replies.
Skip to toolbar