Support » Fixing WordPress » TinyMCE and WordPress 3.2 not working

  • Resolved tele2rn


    I recently upgraded to WP 3.2.1 and as a result Tiny MCE no longer appears in the visual editor anywhere in my wp-admin.

    My server is fully compliant, with version 5+ of PHP and MySQL, and I have been reading forums on, and on moxie about other people having this problem. I have tried every solution that has been suggested, and I have had not luck. Whenever I go to any page that should have a visual editor in it, I get the following error:

    tinyMCE is not defined
    Line 2100

    Please tell me that there is an update forthcoming to fix this, I am at a loss as to how to fix it, and My client is not enthused.

    Thanks in advance for your time and help with this situation. I look forward to hearing from any of you that might have any ideas. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.


    Thanks for your reply, and yes I have tried all of those things and many more, and nothing has made the tinyMCE work.

    Any other ideas? I appreciate your help, Thanks!



    Forum Moderator

    – switching to the Twenty Eleven theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade manually using wp-admin/upgrade.php.


    I have already tried the first three, but how do you rerun the upgrade manually if you are fully up-to-date. When I go to the upgrade page, is says that I am up-to-date.



    Forum Moderator

    1. You could have a corrupt file, so the new files won’t come amiss.
    2. The upgrade may have been interrupted previously, so trying to re-run it won’t hurt either

    Whatever this is, it’s specific your site/install.

    I have manually installed everything (from the wp core software) from a fresh download to my server twice via FTP. The only thing that I have not tried is deleting all my plugins and replacing them one-by-one from fresh downloads. The reason for this is that the plugins are not causing this issue since my admin still errors even when the plugins are not installed, so I did not see the point in doing this.

    I still don’t know how to rerun the upgrade. My wp-admin says I am up-to-date, and does not give me an option to re-run the upgrade

    Thanks for your help, if you can think of anything else, I would appreciate it…thanks, talk to you soon.



    I contacted my hosting provider, and they said that it was a php issue. Here is what they said…

    “We had the same thing happen when we upgraded another site. The problem is with parsing java script files with php. Other versions it hasn’t mattered but with this last version it does. I updated the apache virtual host file so that the Java Script files are not being parsed anymore.”

    This has fixed the problem for me…I hope this helps someone else…



    I had a similar problem. tinymce not work, but no error showed.
    I replace the files on wp-admin e wp-include and the problem was solved.

    thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘TinyMCE and WordPress 3.2 not working’ is closed to new replies.