Support » Fixing WordPress » TinyMCE and Firefox

  • Resolved Moodles


    I have installed the Extended TinyMCE plugin on a WordPress 2.0.5 blog. It works in I.E. but not in Firefox

    In I.E., the last 3 buttons extended the text area so they were ovelapped by the WP right hand options (disucssion, password etc.) which also triggered a WP popup window (are you sure you want to leave this page?) When I moved some buttons (in advanced-wysiwyg.php) to another button row, this fixed the above problem.

    In Firefox, those same 3 buttons are the only buttons that show in the TinyMCE/WYSIWYG area, though the select menus do in the 2nd row, and also in the 3rd row, the “more” button.

    I think the rest of the buttons are actually there, but off to the left and somehow “behind” the layout of the page and the background of the textwriting area. If I try to select and copy in this area, then paste it say, in an email body, the buttons show up in what is pasted, so they are there, just not visible in the layout/display.

    Can anyone here comment? I’d only use this with Firefox and would sure like to get it working with FF so I don’t have to get IE going just to post.

    Thank you for your time.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’ve been continuing to find the answer on this one. (I also tested with Opera and the plugins work fine.) In spite of how that sounds I don’t believe it is a Firefox issue; I’ve been to the TinyMCE site and their version of the full TinyMCE shows up fine in FF. It seems to be about the rich text editor UI area and how it displays in Firefox *on WordPress.*

    I uninstalled the extended TinyMCE plugin and tried the Mudbomb WYSIWYG plugin; same issue, only 3 buttons show, the rest are not visible in Firefox but are in I.E. IF I try to select the WYSIWYG buttons and copy, then paste elsewhere, now I end up with 4 button images, one new button that didn’t show up before. Where was it on the page before … hiding somewhere off to the left, or possibly though I don’t know how this could happen unless with z-index quirks, stacked one on top of each other.

    FYI this is a brand new installation of WP, no other plugins are activated. Default theme. I have javascript enabled.

    I think this has something to do with the WP page/CSS since the same thing is going on with WP on 2 different plugins. I am guessing that it is an oddity in page WP html/css. I also know this theory sounds off because some people *have* used the plugins and FF and WP and not had any problems at all, but I’ve tested everything I can think of and as fas as I can tell it’s related to WP.

    I searched a lot on this here in the forums. Many people have had rich text editor problems, though not all are FF related. But I am also guessing that some of them have also had this same problem with buttons off to the side, as with a negative margin, but didn’t notice.

    One of the comments on the Mudbomb page had the answer. It *is* within Firefox, userContent.css, though I don’t see how TinyMCE could work for my Firefox on one site and not another.
    Poster dtwist — May. 10, 2005 @ 2:56 AM

    The solution is this:

    I’m fairly sure he’s using the userContent.css chunk found here:
    There’s a css selector in there that kills any img element with “/adv” in it’s src string.
    As the editing buttons’ src path contains “/advanced”, it gets selected.
    either delete this line:
    or, as I did, replace it with:

    I hope this solo adventure of mine helps someone else.

    I hope this solo adventure of mine helps someone else.

    Ya know? I bet it will. Thanks for posting the follow-up!

    I just had the same tinyMCE problem mentioned above. I noticed it after I changed Java settings in Firefox. I made a change earlier today and since then I had the same error as Skyline when I clicked on the HTML button.

    I changed my settings in Firefox by clicking Tools > Options > Javascript Popups : Then use the drop-down box to select Unresized Popups. That solved it for me.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘TinyMCE and Firefox’ is closed to new replies.