WordPress.org

Support

Support » Plugins and Hacks » [Resolved] TinyMCE 4.0.1 not showing on WP 3.9

[Resolved] TinyMCE 4.0.1 not showing on WP 3.9

  • karunaray
    Member

    @karunaray

    Just updated WP to 3.9 followed by updating TinyMCE to 4.0.1 after it first update to 4.0

    Made no difference. Cannot even put cursor in post field, none of the icons show. Now I regret updating WP! Can’t imagine posting without TinyMCE. Please advise! Did clear Firefox cache but did not restart. Tried that with 4.0 but it didn’t work, then saw here that 4.0.1 was available. Doesn’t work in Chrome either.

    https://wordpress.org/plugins/tinymce-advanced/

Viewing 15 replies - 1 through 15 (of 26 total)
  • Plugin Author Andrew Ozz
    WordPress Dev

    @azaozz

    Do you see any JS errors in the browser console? A number of bundled JS libraries were updated in WP 3.9, could be an unrelated script.

    karunaray
    Member

    @karunaray

    That’s a little advanced for me! Learning on the fly here. This is what I see, please help:

    uncaught exception: module definition dependecy not found: tinymce/util/Tools
    “Failed to load: http://reikihelp.com/blog/wp-admin//plugins/textcolor/editor_plugin.min.js” wp-tinymce.php:2
    “Failed to load: http://reikihelp.com/blog/wp-admin//langs/en.js” wp-tinymce.php:2
    “Failed to load: http://reikihelp.com/blog/wp-admin//plugins/charmap/editor_plugin.min.js” wp-tinymce.php:2
    “Failed to load: http://reikihelp.com/blog/wp-admin//themes/modern/editor_template.min.js” wp-tinymce.php:2
    “Failed to load: http://reikihelp.com/blog/wp-admin//plugins/hr/editor_plugin.min.js

    karunaray
    Member

    @karunaray

    Anyone? Plugin author? Never had a problem with this plugin with previous WP updates. I was just getting ready to post. I really need to post. Please provide a solution.

    Plugin Author Andrew Ozz
    WordPress Dev

    @azaozz

    That’s a little advanced for me! Learning on the fly here.

    This is a good debug info 🙂 Unfortunately it doesn’t make it clear what exactly is causing these errors. Best guess is that the file wp-tinymce.js.gz has failed to update. To fix that download a fresh copy of WordPress 3.9, unzip it to a folder on your computer, then replace that file with FTP. It is wp-includes/js/tinymce/wp-tinymce.js.gz.

    Can also try to re-install 3.9, but it may fail to update that file again.

    karunaray
    Member

    @karunaray

    That worked, thanks so much!

    susan.powers1
    Member

    @susanpowers1gmailcom

    I am having the exact same problem. But the fix above is a bit advanced for me. Can you explain a little more detailed what I need to do?

    karunaray
    Member

    @karunaray

    Well… When you download the WP 3.9 files to your computer, they’re zipped. If you right click on the downloaded folder and find unzip in the menu, you’ll be able to find individual files once that’s complete. Then you have to locate the one the author of this plugin mentioned above.

    After that either using an FTP program that has access to your site files on your host’s server, or perhaps your host gives you access to your site files in another way, you have to upload that specific file which is found at wp-includes/js/tinymce/wp-tinymce.js.gz to your host’s server in the same folder as wp-includes…, etc. However you upload it, it will ask if you want to replace/overwrite the existing file by the same name. Select yes and you’re good to go.

    May need to log out of your blog and log back in or just refresh the post page so you see the visual editor.

    susan.powers1
    Member

    @susanpowers1gmailcom

    Okey dokey then.

    Thanks!

    I have the same problem. I did follow your steps to replace wp-tinymce.js.gz file in /wp-includes

    I also tried to intall WP 3.9 again. Tried to deactivate the plugin and reactivate it. Tried to uninstall and install again. But non of these things worked.

    Is there something else i can try?

    Alexander Albrecht
    Participant

    @alexander-albrecht

    same here. did all these steps. reinstalled wp 3.9, replaced the mentioned file. nothing works. here i get a 404 on a resource not found:

    wp-includes/js/tinymce/plugins/inlinepopups/plugin.min.js

    This resource is not even on a fresh downloaded copy of WP 3.9 to be found.

    Sctdesign1
    Member

    @sctdesign1

    I have the same problem. My site just up dated and the tinymce-advanced stop showing up in my pages edits. I was working on a clint site with a deadline what do I do?

    Alexander Albrecht
    Participant

    @alexander-albrecht

    Hey folks, found the problem on my pages. I’ve used to have some TinyMCE modding code in my functions.php which was totally unnecessary and blocked the new TinyMCE from loading. Removing that code ever<thing is fine. Now back to work.

    Well in my case the problem occurs due to an error in a theme javascript file. So no problem with the plugin itself anymore.

    I just reinstall 3.9_ru, replace wp-tinymce.js.gz, uninstall/install TinyMCE Adv, but still it doesn’t work. 🙁 There is no changes in js file in theme, no error while loading edit page.

    Plugin Author Andrew Ozz
    WordPress Dev

    @azaozz

    Yes, most of these errors are usually caused by a plugin (or some code in functions.php in the theme) that needs updating.

    To debug: switch to one of the default themes, clear browser cache, test. If still broken, start disabling plugins one by one, clearing cache and testing after each until the broken one is found.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘[Resolved] TinyMCE 4.0.1 not showing on WP 3.9’ is closed to new replies.