Support » Plugin: WP Bing Map Pro » Tiny MCE html editor not loading Error

  • Resolved morris373

    (@morris373)


    Hi
    Clicking on Advanced, I get this error ‘Tiny MCE html editor not loading’. Am I suppose to install the TinyMce plugin or does it uses the one already installed with WordPress?

    Is this the reason that the Pin Infobox is empty? I would have thought it used the name and address.

    Thanks

    Morris

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author dan009

    (@dan009)

    Hi,

    Thank you for using WP Bing Map Pro.
    The plugin uses WordPress tinyMce library for rich html. (advanced infobox)
    For some reasons the plugin cannot load the library to display the editor. I’ve enumerated in the modal some of the reasons.
    It does not use the name and address you’ve entered in the pin fields. Advanced infobox is used to display html content.
    To display simple text like address and name, you could use simple infobox.

    Try creating a new user with administration permissions, and see if it loads the editor (working solution from other users, which previously had this issue).

    If you have any other queries let me know.
    Regards.

    Thread Starter morris373

    (@morris373)

    Hi Dan
    I should have tried that as it was mentioned but I don’t understand why that works.

    It is now working and it looks great.

    Your Plugin is one of the easiest to use and setup.

    Thanks for your quick help and support.

    Morris

    Update: It works once and now I have the error message again.

    • This reply was modified 11 months, 3 weeks ago by morris373.
    Thread Starter morris373

    (@morris373)

    Hi
    I have checked the folder permissions for TinyMCE and they are set to 755.

    I have changed the Theme, still not working.

    I have deactivated all Plugins except Bing Map Pro and still not working.

    I have saved Permalinks twice, still not working.

    PHP is set to Version 7.3

    WordPress has been updated to version 5.5

    Tried adding a new Pin and didn’t work.

    I have tried everything I know and I still can’t get it to work.

    For now as I only had 6 pins, I added the infoformation to the Infobox via the database and for now it is working. Not ideal but jobs done.

    Thanks

    Morris

    • This reply was modified 11 months, 3 weeks ago by morris373.
    Plugin Author dan009

    (@dan009)

    Try this solution.
    Check your httpaccess file in your WordPress root folder or WordPress wp-includes folder. Backup it and then Delete it and reactivate it by your website admin area changing permanent links or super cache admin something like that. You do not need to create htaccess file by your file manager.

    Also try

    1. make sure that the “disable visual editor” was not checked
    2. make sure that your browser is up to date
    3. Try clearing your browser’s cache and cookies
    4. try deactivating and reactivating the themes and plugins
    5. create an user by admin area not by phpadmin
    6. Delete Cache of all logs by File Manager
    7. change to a different theme
    8. Change “Display name publicly as” to your Nickname
    9. Check wp-config.php file for cache file location
    10. install classic editor plugins
    11. permalinks, change to “plain” or another, save changes, then try back
    Thread Starter morris373

    (@morris373)

    Hi Dan
    I tried all that before what you mentioned, but I found this Blog and I followed Option 5 on => https://blog.hubspot.com/website/wordpress-visual-editor-not-working

    At first it didn’t work but I opened a page up and the TinyMCE was there but that wasn’t the issue as it’s always worked.

    After opening a page, I opened Pins again and the Visual Editor came up in Advanced and Simple Mode. I couldn’t get Simple Mode to work either and now it is.

    I see if my other 2 websites will work when I add the same line into wp-config.

    I will let you know later if it works or not.

    Thanks

    Morris

    • This reply was modified 11 months, 3 weeks ago by morris373. Reason: Spelling
    Thread Starter morris373

    (@morris373)

    Hi Dan
    I quickly tried it on another website and it worked with that piece of code added to wp-config.php.

    Again it didn’t work at first so maybe clear the cache and refresh the page but I did open a couple of Pages first.

    Now working, I will use the same technique on another website.

    Thanks

    Morris

    Plugin Author dan009

    (@dan009)

    Hi,

    That’s great.

    I’ll play with wp-config.php to change the values and see how the scripts behave.

    If all works well, and is stable, I’ll make a post.

    Thx for finding the fix, also for using the plugin, will appreciate if you could rate it.

    If you have any suggestions in functionality let me know.

    Can I mark this topic as fixed ?

    Regards.

    Plugin Author dan009

    (@dan009)

    Hi,

    Is it resolved for you?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Tiny MCE html editor not loading Error’ is closed to new replies.