[resolved] Tiny MCE and CKEditor not working or showing in 3.3 rc1 (14 posts)

  1. tucatjack
    Posted 3 years ago #

    I have tried every possible way of getting either TinyMCE or CKEditor to work in 3.3 with no luck. Hs anyone gotten this to work?

  2. TinyMCE is built into the Visual Editor and works fine. What are you trying to do that isn't working?

  3. tucatjack
    Posted 3 years ago #

    I am trying to figure out why I no longer see the Visual and HTML tabs in the upper right corner of the editor. All I get is a line of words with no icons. Can't even find the kitchen sink anymore. If I install Advanced TinyMCE or CK Editor the tool bar remains the same without adding anything to the toolbar.

    Now I have tried everything that I can read about on this forum as well as others. This is a clean install of WP 3.3 RC-1 with all plugins turned off and no additional plugins besides the standard two Hello and Akismet, neither of which is activated. The Visual Editor radio button in my profile is not checked and I have checked and unchecked it to no avail.

    So could you enlighten me as to how you got yours working.

  4. Nothing special, I just installed WP and they worked.

    Delete the core files and re-upload.

    If it's still not working, what version of PHP are you running?

  5. tucatjack
    Posted 3 years ago #

    Already tried deleting and re-uploading the core files. Deleted every cache on every browser and still get the same result. Tried it on my remote server and got the same results. Here at my development server I am using php 5.3.6. I've tried the install as an upgrade and as a clean install. It really has me puzzled.

  6. ReneODeay
    Posted 3 years ago #

    Has this been resolved? cuz I'm having similar problem with an upgrade to WP 3.3, except the tabs show up, but I can't switch to the visual editor.

  7. soulstaker
    Posted 3 years ago #

    Just got this doing a clean install of WordPress too.

    lighttpd 1.4.29
    mysql 5.5
    php 5.3.8

    http://i.imgur.com/jpT4o.png <- looks like this.

    the flyout menus doesnt work too

  8. Tobias Beuving
    Posted 3 years ago #

    Same here, it does not replace standard textareas for TinyMCE instances as it used to in WP 3.2

  9. ReneODeay
    Posted 3 years ago #

    They're letting us hang in the wind. what shame, since 3.2 didn't seem to have ANY of these issues.

  10. ReneODeay
    Posted 3 years ago #

    even the Beta 3.3 candidate didn't have these problems.

  11. esmi
    Forum Moderator
    Posted 3 years ago #

    Try working through the solutions listed in http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    Since 3.3 is now live, this is no longer an Alpha/Beta issue.

  12. Tobias Beuving
    Posted 3 years ago #

    I found the cause of my problem:

    In the firebug-console I noticed that TinyMCE apparently was looking for the following language file:


    but in the folder : wp-includes/js/tinymce/langs/ where only two files:

    I downloaded the english language pack from: http://www.tinymce.com/i18n/index.php?ctrl=lang&act=download&pr_id=1

    Copied it in the 'lang'-folder and now everything works again!

  13. soulstaker
    Posted 3 years ago #

    thanks esmi, figured out how to solve this visiting your link.


    Just uncommented these 2 lines on my php.ini and restarted lighttpd.

  14. 13hands
    Posted 3 years ago #

    Made it to c-panel...whew..
    When you put the en.js file in the TinyMCE folder, did you delete
    the wp-langs-en.js that was orginally there?

    soulstaker, kindly explain the code you shared
    Thanks....not working yet...

Topic Closed

This topic has been closed to new replies.

About this Topic