Support » Fixing WordPress » tincyMCE error

  • Nimesh

    (@nimeshrathod1gmailcom)


    Hello All,
    I have use 4.9.8

    I have one textarea like below :
    wp_editor( $content, $editor_id , $settings = array( 'media_buttons' => false , 'editor_height'=> '100px' ));

    When I will click on “Visual” tab, it will give below console error :

    Uncaught TypeError: Cannot read property 'onpageload' of undefined
    
    FILE
    
    /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716
    
    at tinymce.min.js?ver=4800-20180716:2
        at e (tinymce.min.js?ver=4800-20180716:2)
        at je.b.bind (tinymce.min.js?ver=4800-20180716:2)
        at Object.F [as bind] (tinymce.min.js?ver=4800-20180716:2)
        at Object.init (tinymce.min.js?ver=4800-20180716:2)
        at e (editor.min.js?ver=4.9.8:1)
        at HTMLDocument.<anonymous> (editor.min.js?ver=4.9.8:1)
        at C (tinymce.min.js?ver=4800-20180716:2)
        at HTMLDocument.d (tinymce.min.js?ver=4800-20180716:2)
    
    
    • This topic was modified 4 years, 3 months ago by Nimesh.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Could be custom code in your theme causing the error. Can you post a link to the site or seek support on theme’s support page.

    I have the same issue, but in WordPress 5.0.1. I’m using ACF Pro and TinyMCE and cannot switch back to the visual editor. I get this same error:

    TypeError: r is undefined[Learn More] tinymce.min.js:2:339903

    e /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    e /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    bind /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    F /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    init /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    switchEditor /wp-admin/js/editor.js?ver=5.0.1:134
    init /wp-admin/js/editor.js?ver=5.0.1:34
    C /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2
    d /wp-includes/js/tinymce/tinymce.min.js?ver=4800-20180716:2

    Did you find some kind of solution??

    I am having a strange tinymce problem. When i use firefox i can’t see visual editor buttons. But in chrome everything works as expected.

    Receiving the same error in a custom extension on a Woocommerce product page

    Both the main product content and the product excerpt work as expected.

    I tried mimicking the setting from the WooCommerce–no joy. The only plugins I have running are WooCommerce, WooSubscriptions, and the custom project.

    Here’s what I’ve got (that’s not working):
    wp_editor( htmlspecialchars_decode($content), “wsrtp-tier”, array(
    ‘editor_height’=&gt;250,
    ‘quicktags’ => array( ‘buttons’ => ’em,strong,link’ ),
    ‘tinymce’ => array(
    ‘theme_advanced_buttons1’ => ‘bold,italic,strikethrough,separator,bullist,numlist,separator,blockquote,separator,justifyleft,justifycenter,justifyright,separator,link,unlink,separator,undo,redo,separator’,
    ‘theme_advanced_buttons2’ => ”,
    )
    ));

    • This reply was modified 3 years, 10 months ago by chasewg.
    • This reply was modified 3 years, 10 months ago by chasewg.

    I came across this on the wp_editor page on developer.wordpress:

    NOTE: Once initialized the TinyMCE editor cannot be safely moved in the DOM. For that reason running wp_editor() inside of a meta box is not a good idea unless only Quicktags is used. On the post edit screen several actions can be used to include additional editors containing TinyMCE: ‘edit_page_form’, ‘edit_form_advanced’ and ‘dbx_post_sidebar’. See https://core.trac.wordpress.org/ticket/19173 for more information.

    For my part, this is what I was doing wrong

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘tincyMCE error’ is closed to new replies.