TimThumb Thumbnail not displayed (6 posts)

  1. whitehats
    Posted 6 years ago #

    Hi All,
    I have a custom theme for my upcoming gallery website http://www.footerama.com.

    I have currently one post up as an example of the problem I'm having. Until I can get it resolved I can let the entire database go live.

    On the homepage, the resized images are created using a Post-Resize function from here - http://snipplr.com/view/14280/get-wordpress-image-attachment-and-use-tim-thumb-to-crop/

    So I don't need to use custom fields to crop my image. Additionally I am scaling the image to a width of 900px using 2.9 image scaling functionality.

    The image URL I set is of the website from where I feature the gallery item. So it is not the path of the image file. (User should be able to click on the image and go to a different website)

    This setup works perfectly on my local machine with WAMP.

    On the live server though, I don't see any thumbnail on the homepage. When I right click and go to the thumbnail, I get a 404 error.

    Where could I have gone wrong? I have tried 777-chmoding all folders, changing file names to not contain special characters. But it hasn't helped.

    What else could I do to achieve my desired results?

  2. Stian Andreassen
    Posted 6 years ago #

    Have you created a cache folder within the scripts folder?

  3. whitehats
    Posted 6 years ago #

    Yes. Actually isn't that something Timthumb automatically creates? It's been set to 777 for now as well.

    I tried using Get_post_image plugin for this, but the images fade and are not 'crisp' with that plugin the way I could make them with timthumb.

  4. Stian Andreassen
    Posted 6 years ago #

    Have you tried using catch_that_image? I have used that in combination with timthumb ...


  5. sam_h1
    Posted 6 years ago #

    Is the host to your live version running an up-to-date version of php?

    I'm struggling with timthumb myself at the minute, but i've read in places that the php version makes a difference :)

  6. rooboy
    Posted 6 years ago #

    I had a similar problem also this week after upgrading my WAMP (XAMPP). It's linked to the PHP version I reckon, I fixed it by installing a later (beta) version of the timthumb from this post on the TimThumb site.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic