WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Timthumb not working

[Resolved] Timthumb not working

Viewing 15 replies - 1 through 15 (of 16 total)
  • What are the permissions on the cache folder? Also, I found this guide at Hostgator, it might be of some use to you:

    http://support.hostgator.com/articles/specialized-help/technical/timthumb-basics

    Donorbrain
    Member

    @donorbrain

    People of wordpress,..

    I have this annoying issue with Timthumb. I’m not sure what is causing the problem but it’s a common problem from what i’ve read. Timthumb won’t generate thumbnails. I’ve checked the CHMOD of the files and folders needed for this script. I’ve checked if a GD library is running,.. i’ve checked caching… but still nothing.

    The frustrating thing is.. the same script from the same theme will run properly on this domain which i’ve used as prototype for this website:
    http://droogh.donorbrain.com/

    BUT IT WON’T WORK HERE (sorry caps) :
    http://www.mauricedroogh.com/testwebsitemaurice

    The only difference is different providers.. And one difference is that i’ve imported the content from droog.donorbrain.com to testwebsitemaurice using wordpress XML export and import,.. perhaps that messed things up but i doubt it.

    If anyone can help or point me in the right direction that would really be appreciated !

    Thanks!
    Jacco

    WPyogi
    Forum Moderator

    @wpyogi

    @donorbrain – please start your own thread as per the forum guidelines –

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    You can do so here:

    How-To and Troubleshooting

    Donorbrain
    Member

    @donorbrain

    Sorry, for multi posting.. i was just afraid no one would answer my questions since it’s pretty urgent for me to fix it.

    Warren
    Participant

    @rabbitwordpress

    Did anyone figure this out yet?

    We have the same Timthumb problem!

    I see the images on : http://www.pwfloorsinc.com are working @darkmatter661 ! How did you fix this?

    esmi
    Forum Moderator

    @esmi

    @warren: If you require assistance then, as per the Forum Welcome, please post your own topic.

    Warren
    Participant

    @rabbitwordpress

    Hi Esmi,

    I just realised its not a WP theme, its Mio for Woocommerce!

    I volunteered to take a look at the problem for a client I did a different normal WordPress site for and after about 4 hours of searching and trying different things I got nowhere. The images just don’t show unless the theme is changed.

    Thanks anyway
    Warren

    @warren Just in case you wander back in here, there’s no such thing as a WooCommerce theme. There are themes such as the one you’re using that may be optimised or specifically tailored for WooCommerce, but they are WordPress themes.

    darkmatter661
    Participant

    @darkmatter661

    From what I can recall, all folders should have permissions (chmod) of 755, especially the cache folder. All files should have permissions of 644, especially the timthumb.php file. Make sure you have the latest timthumb.php version installed.

    Warren
    Participant

    @rabbitwordpress

    Hi @wpranger,

    Thanks for the update! I was only trying to help someone out but had to give up in the end, I just couldn’t get the images to show with Mio theme. I can’t believe how long I spent trying different things.

    WordPress is fantastic for most sites but not ecommerce, in my limited experience with WooCommerce anyway. I would normally choose OpenCart or Magento given the choice.

    Cheers anyway mate!
    Warren

    Donorbrain
    Member

    @donorbrain

    The problem for me is resolved.. Thanks to my hosting provider.
    I couldn’t figure it out myself.. I tried special plugin’s that would check if TimThumb is up to date and secure, CHMOD , everything.

    My hosting provider told me the problem was fixed because there was a declaration in a .htacces file which would point to PHP 5.5 ,. they changed it back to the server standard PHP version which they told me is: 5.3.3

    I hope now not other functionalities will cease working because of this version 5.3.3. of PHP.

    Btw my hosting provider is Hosting2Go ..Anyone had experiences with them?

    darkmatter661 You seem to be offering answers to your own support topic here. I’m confused!

    Did you fix your original issue?

    Warren
    Participant

    @rabbitwordpress

    Hi @donorbrain,

    Thanks for the info, I’ve just disabled the .htaccess file and hey presto it worked! All the images on the homepage show up again. I’ll work out which line is causing the problem and will post it here.

    Thanks for the top tip!
    Cheers
    Warren

    Jan Dembowski
    Volunteer Mod. & Brute Squad

    @jdembowski

    darkmatter661 You seem to be offering answers to your own support topic here. I’m confused!

    Me too. 😉 This topic seems to have gone off track. Darkmatter661 can you let us know if your topic is resolved or not?

    darkmatter661
    Participant

    @darkmatter661

    The answer I provided was what I believe I did to fix my problem 🙂

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Timthumb not working’ is closed to new replies.