Support » Plugin: Simple Calendar - Google Calendar Plugin » Timezone set to Default not changing properly

  • ngoodfellow

    (@ngoodfellow)


    Hey Ross,
    I am having some issues with the plugin you can see here:

    I currently have my sidebar calendar feed to show daily events:
    http://salvationpizza.com/dev/events/

    I have set to retrieve events from: Today: 0
    and retrieve events until: Today: 86400

    In theory this should display only todays events on the sidebar

    I have set the timezone to America/Chicago for Central Standard Time

    My wordpress Admin is set to properly offset UTC-5 and displays the proper local time.

    Events display properly on the sidebar until 7pm… at 7pm sidebar switches to the next day! so for some reason it is still pulling from the default time() instead of current_time( ‘timestamp’ )

    I have been digging through the code and I’m just not sure how to fix this!

    I tried putting manual offset but the issue remains because it is based off Today and current time… not sure how this all works together still

    The issues mainly seems to be when displaying events that occur TODAY or start on TODAY
    http://wordpress.org/plugins/google-calendar-events/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Ross Hanney

    (@rosshanney)

    Hello,

    I think this may be due to a bug in the current release, which should be fixed in the development version, if you want to try that out.

    ngoodfellow

    (@ngoodfellow)

    http://salvationpizza.com/dev/events/

    I updated to the dev version. Now the calendar is only showing 7 days of events even though its set to display 50… is there a option for the shortcode to fix this?

    Plugin Contributor Ross Hanney

    (@rosshanney)

    What do you have the “Retrieve events from”, “Retrieve events until” and “Maximum number of events to retrieve” options set to?

    ngoodfellow

    (@ngoodfellow)

    Retrieve events from Today 00
    To: end of time

    display: 50

    ngoodfellow

    (@ngoodfellow)

    I tried changing to a manual offset

    To End – Today: 5184000 (60 days)
    still only showing 7 days on shortcode
    my shortcode looks like this:

    [google-calendar-events id=”2″ type=”ajax” title=”Events on”]

    Plugin Contributor Ross Hanney

    (@rosshanney)

    Could you let me know the feed URL you’re using?

    ngoodfellow

    (@ngoodfellow)

    ngoodfellow

    (@ngoodfellow)

    It looks like possibly the dev script isn’t recognizing the repeating events on google calendar? it was working before…

    Plugin Contributor Ross Hanney

    (@rosshanney)

    There’s a new option in the dev version called “Expand recurring events?”. Is this enabled?

    ngoodfellow

    (@ngoodfellow)

    lol, I totally missed that button, Thanks Ross!

    I will know at 7pm if the timezone issue is resolved with the new dev plugin! I appreciate your hard work and effort on this plugin and it looks like the dev is working great! do you need any additional help to get it ready to publish?

    Plugin Contributor Ross Hanney

    (@rosshanney)

    I’m holding off on releasing the dev version as I really need to update the plugin to the new Google Calendar API (a big job), but bug reports are always welcome!

    ngoodfellow

    (@ngoodfellow)

    dude, you have a great plugin here! I have used it several times and the beta is working great! let me know if you need any help with updating things!

    Also, check out my latest web project… its a fun and FREE online game!

    Are You Prepared?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Timezone set to Default not changing properly’ is closed to new replies.