Support » Plugin: The Events Calendar » Timezone Defaults to UTC instead of Site-Wide Europe/Berlin and seem unsorted

  • Hi,

    we have just updated WordPress to most recent version and switched from PHP 7.1 to PHP 7.4. In addition, of course, we updated the Events Calendar Plugin.

    Different to before, when creating new events, the timezone selector is now set to “UTC” always. This is especially irritating for “whole day” events, as they are suddenly displayed to range 2 days instead of just one. So, obviously, in display the correct local time-zone is considered.

    Unsorted Which makes it worse: The timezones seem sorted rather randomly. If you search for Berlin, it will appear near the bottom of the list:

    Melbourne
    Perth
    Sidney
    Amsterdam
    Andorra

    Berlin

    The problem: The timezones are grouped by Australia, Europe etc., just as they are grouped in global timezone setting in WordPress. But in Events Calendar the continents are not displayed, providing no guidance.

    Both bugs increase the severity and make the calendar pretty unusable 🙁

    Note, that I have chosen site-wide timezones to take (and it is set to Europe/Berlin).

    Interesting: If you switch display of time-zones on in editor, it will be displayed as “Europe/Berlin” but the field settings will tell, it is “UTC”.

    This issue seems similar to many other issues out there… but all of them seem to be “closed”. Examples:

    https://wordpress.org/support/topic/event-in-wrong-timezone/
    https://wordpress.org/support/topic/time-zone-issue-12/

    Would be great, if you could help.

    Cheers,
    Mark

Viewing 4 replies - 1 through 4 (of 4 total)
  • My name is damonde from Japan.
    I have a same time zone problem. Please help me soon, too!
    The time zone of wp-admin is Asia/Tokyo, but in the block of a new event post page it is displayed UTC time. Even if I change the time zone setting method of the configuration, the block time zone is always UTC, so I have to change it manually each time. Otherwise, the time of the event is displayed on the calendar in UTC time plus 9 hours later.
    I tried to disable themes and plugins. But nothing has changed. So this cause is not the themes or plugins.
    I think it was working correctly 2 months ago. Please tell me how to display the time zone Asia/Tokyo in the block.
    WordPress 5.4.2 PHP 7.3 Theme: Lightning Using:Elementor
    https://od-planet.com/events/

    Mark

    (@thragor)

    Same as https://wordpress.org/support/topic/problem-of-time-zone-utc/

    My workaround for now: Disable Gutenberg blocks in settings. The old editor works as expected.

    Plugin Contributor András Guseo

    (@aguseo)

    To give you an update, we are already working on a fix and hope to ship it in the next release. Target is end July.

    A.

    Plugin Support Jaime

    (@jaimemarchwinski)

    Hi @thragor

    Hello,

    Just wanted to let you know that a new maintenance release is out, including a fix for the issue that you were experiencing.

    Find out more about this release → https://theeventscalendar.com/release-notes/the-events-calendar-5-1-5/

    Please try updating and let us know if you are experiencing any further issues. As always, we recommend running updates on your staging site before doing so on your live site, just to be on the safe side.

    Thanks again for your patience while we worked on getting this fixed!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.