• Resolved Paul

    (@paulka)


    Firslty great and simple Thanks!

    I have a timer setup with the following options:

    Mode: Evergreen
    Auto-restart when session expires?: None
    Products : All products
    Woocommerce: Enable
    Actions: Hide countdown timer

    I’m not sure if I set it up wrong, but it doesn’t work the way I might have expected. When the counter hits zero, since the option do not auto restart is not ticked, I expect it not to come back. However, if the page is reloaded it starts again. Also the same timer on each product starts individually, not with the same countdown, even though I only have one timer setup.

    What I want is the timer to hide when it reaches zero and never display again, until the cookie is lost or the IP changes.

    • This topic was modified 2 years, 4 months ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Nabil Lemsieh

    (@nlemsieh)

    Hello,
    Thank you for your feedback,

    Can you share your site, so I can look into that?

    Thread Starter Paul

    (@paulka)

    Thanks @nlemsieh

    I have set this to only display on this product, disabled wp hyper-cache on this page and disabled cloudflare on this URL.

    It seems every time I refresh the page it re-appears. The timer is set to 30 seconds, hopefully, its enough to test.

    Also double checked and “Auto-restart when the session expires?” is definitely set to ‘none’

    • This reply was modified 2 years, 4 months ago by Jan Dembowski.
    Thread Starter Paul

    (@paulka)

    It appears to be working now on the uncached page. Is there for it to work with page caching?

    Plugin Author Nabil Lemsieh

    (@nlemsieh)

    Hello,

    Thank you for the follow-up.

    Evergreen countdown timers rely on cookies for detection. When a page is cached the served cookies are empty, so we can’t determine when the countdown has started, for that reason the countdown timer keep resetting each time you reload the page.

    We’re working to bypass the caching.

    Thread Starter Paul

    (@paulka)

    That’s great, on clearing my Cloudflare cache it does affect it. Looking forward to a cacheing friendly option

    Plugin Author Nabil Lemsieh

    (@nlemsieh)

    Hello,

    We shipped a new release that includes the ability to bypass cache.

    Let me know if that worked for you

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Timer always resets after 0’ is closed to new replies.