Support » Plugin: Autoptimize » Timeouts with WordPress Dashboard

  • mnorth

    (@mnorth)


    I’m having increasing problems with pages opening in my WordPress admin pages if Autoptimize is installed. Suddenly pages would not open and I’d get a message saying that the process has timed out at 180 sec or so and Autoptimize would be listed in the message. I’d have to go into my site via FTP and rename the plugin before things started working again.

    I’d reinstall Autoptimize and things would work for a while and then the same issue would arise. Clearing the caches didn’t make any difference that I could tell. Today I had the same problem and followed the same procedure, but this time pages would immediately not load, so I disabled Autoptimize and pages would load again.

    I should also note that while Autoptimize was installed, I’d lose connection with the server and pages that were open for editing. Again, if Autoptimize is disabled, I don’t have this problem.

    This only started to happen with version 2.3.4 as far as I can tell.

    • This topic was modified 1 month ago by  mnorth.
Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    That’s pretty weird @mnorth, AO doesn’t do a whole lot on the backend … Can you provide me withthe exact “message saying that the process has timed out at 180 sec or so and Autoptimize would be listed in the message”? Do you have any info in the PHP errorlog concerning AO?

    frank

    mnorth

    (@mnorth)

    I’d have to reinstall the plugin and then wait to have it happen once more. I’m currently working on a story that will be published on Friday and I don’t want the potential hassles and delays until that’s done.

    All I get is a single line text saying that the process has timed out and then a string with Autoptimize listed as the cause of the timeout. I didn’t think to copy and save the text. This has happened several times and it’s always Autoptimize that causes the failure for the page/s to load and only when I into my hosts server’s Ajaxplorer and rename the plugin that the problem is fixed.

    I’ll reinstall the plugin on Saturday and wait until the issue arises once more. I’m not saying that the plugin is directly at fault, as it may have something to do with the LightSpeed server configuration as well.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, I’ll await further info. Maybe check the php errorlog as well (now that it’s still fresh)?

    mnorth

    (@mnorth)

    I’d have to reconfigure my php-config file and I don’t want to start playing around with code anymore than I have to. I’m cloud hosted so I don’t have cPanel.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, I’ll hang in there 🙂

    mnorth

    (@mnorth)

    I haven’t forgotten about this. I reinstalled the plugin on Saturday and I haven’t experienced the issue I described earlier. However, site loading (in the WordPress editing side) is slowing down considerably, which seemed to be the precursor to the error that I received earlier. If I get a repeat, I’ll copy the text warning and update.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    However, site loading (in the WordPress editing side) is slowing down considerably

    Even this is very surprising already.

    Some questions;
    * do you have a view on CPU & memory usage and if so could you compare these with and without AO?
    * are you using a page cache on the front-end?
    * could you check how many files you have in wp-content/cache/autoptimize/css and wp-content/cache/autoptimize/js/?
    * can you try disabling CSS optimization to see if this impacts backend site loading? if no impact can you try disabling JS optimization? (and impact on CPU/ Mem usage would be interesting too)? or HTML optimization?

    frank

    mnorth

    (@mnorth)

    I can’t view CPU or memory.

    I use WP Super Cache.

    I had a look at the wp-content and it lists 22 pages of files. The last page has a css/js folder with nothing in it, or won’t open.

    I’ll have a look at the options you noted and get back.

    mnorth

    (@mnorth)

    I disabled CSS and it appears to be loading faster, including my site, but I’ll keep an eye on things for the next few days before I can confirm that things are stable.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Although no empirical evidence, what _could_ be happening is that the CSS minifier is being called upon a lot on the front-end (despite the page cache) and that this is causing a higher then normal CPU-load causing the backend to become slower.

    Now what would be interesting is if you could switch to AO 2.4 beta which happens to have a much better (as in immensely faster) version of the CSS minifier on board. If the above explanation is correct, then I would expect AO 2.4 to solve the problem. You can download the zip-file from Github here, add it by going to plugins -> new -> upload -> activate (disable the “old” autoptimize first maybe).

    frank

    I disabled JS as well, but once I disabled the plugin, things sped up measurably.

    However, I want to make sure that time of day isn’t having an impact on the site (server load on my cloud hosting). So I’ll run things without the plugin for a few days and see if there’s a trend. So far I haven’t tried a longer period without the plugin installed.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    If possible ask your hoster for some graphs on memory & CPU usage, ideally for a period with and a period without AO.

    Unfortunately, that is just not possible.

    Some more feedback. After disabling the plugin, I wasn’t getting the same timeouts, but I was experiencing connection losses while editing a page. After some investigation, I installed a Heartbeat API control plugin to see what effect this had.

    It’s still early days, but I haven’t had the connection loss since installing the plugin. So I’ll monitor this for a day or so and, if things remain stable, I’ll reinstall Autoptimize and see what happens. If nothing else, this may indicate that there could be an issue with Autoptimize and the Heartbeat API that was causing my initial issues.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    there could be an issue with Autoptimize and the Heartbeat API

    afraid AO does not use the heartbeat API at all @mnorth

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.