Support » Fixing WordPress » Timeouts, Cant Upload Images & Autoposts Not Generating

  • Has anyone seen the issue with WP3.3.3.1 where all is working fine and then you suddenly lose the ability to upload images, create posts, connect to services?

    I have been on 3.3.1 a while and it was all working fine but 48hrs ago I tried to upload some images to start a post off and every image I try in any browser hangs at “crunching”. I have tried all the basics, killed all the plugins etc and no joy. I also realised that the RSS feeds that I have coming in to Autoblogged to generate posts were also no longer working (feeds active and visible but no posts being created). Cache has been cleared also numerous times. Everything has also been tried in the usual default Theme with all plugins active and no plugins active and it made no change at all.

    The articles I read seem to indicate that the most common cause is the themes functions.php file but I dont a have a clue what to look out for? where could the problem lie with the functions.php? Are there any other image uploaders that could be used as a workaround?

    Many thanks and hope that someone knows a fix to this as its completely stopped me doing any new posts.

    Additionally I have also tried to reinstall WP which has always bailed me out before but it didnt. Also no new plugins have been installed or updated over this time. I have spoken with the host (1&1) and they say they cannot see any kind of issue or anything recent that they have applied to the webspace.

    It is as though there is a permission problem where things cannot connect, publish, finalise as it times out. I was advised to change all the security keys on the site which I have done but this has made no difference at all.

    I have been asked to add the following content to my php.ini file which I have done, it now reads as this: (saved to root and wp-admin)

    allow_url_fopen = On

    upload_max_filesize = 150M
    post_max_size = 150M
    max_execution_time = 300M

    memory_limit = 80M

    My HTACCESS file now reads as this which is different from any of my other WP installs but 1&1 advise that it looks fine:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    AddType x-mapp-php5 .php .php4

    Further to add for a quick check my HTACCESS file was quickly changed to the following for a test but after clearing browser cache it made no difference so was reverted back to what it is above.

    # BEGIN WordPress

    # END WordPress

    AddType x-mapp-php5 .php .php4

    Would be good to know what the ReWrite values are relevant to within WordPress or its plugins as I havent gained any clarity on that as yet.

    None of my other sites have anything between BEGIN and END wordpress so I am guessing this is something relevant to a plugin? (rightly or wrongly).

    The thing that I cant presently get my head around is how it can be working fine and then just break with no other settings altered in the meantime and why so many little changes like this are required to fix it?

    I am also struggling to see how the image upload failure and the inability to create blog posts from an RSS feed are linked, unless of course these are both “time out” issues.

    Any help on this one at all would be massively appreciated as the site is just unusable at the moment.

    Thanks alot!


Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    SOLVED 🙂 – The problem was as I first expected, an issue with the MySQL database at the ISP. Was able to prove it and have it corrected.

    Thanks for the help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Timeouts, Cant Upload Images & Autoposts Not Generating’ is closed to new replies.