Support » Plugin: Timeline Express » Timeline Icons Not Displaying

  • Resolved hughes888

    (@hughes888)


    The timeline icons are not displaying. Tried clearing cache & regenerating CSS as well as the usual troubleshooting steps but their still missing. It was definitely working in earlier versions of the module. Not sure how long it has been since it stopped working as I don’t check this site too often.

    Any suggestions please?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Can’t view your website:

    The connection for this site is not secure
    http://www.paulhughes.pro uses an unsupported protocol.
    ERR_SSL_VERSION_OR_CIPHER_MISMATCH

    Do you use FontAwesome icons?

    Thread Starter hughes888

    (@hughes888)

    Sorry about that, I switched to Cloudflare to see if that would help. From what I have been able to ascertain so far, the problem is a CORS issue with Font Awesome. I contacted my ISP (SiteGround) and they suggested to disable NGINX cache (which I have done). I also added some code in my .htaccess to add the header tag but none of these actions has fixed the problem. Because the timeline does not allow for custom icons I don’t have a way to replace the Font Awesome icon with my own icon.
    If I preview the page when I am editing the site in Elementor, the icons display just fine. Not sure why they don’t display on the live site.
    Going bald now from pulling out my hair 🙂

    <IfModule mod_headers.c>
    
      <FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|js)$">
    
        Header set Access-Control-Allow-Origin "*"
    
      </FilesMatch>
    
    </IfModule>

    Do you have a paid Font Awesome account? – if so, might be worth exploring the ‘Kit’ route.

    To be honest I got so frustrated waiting for a response from the developers that I switched to another plug-in altogether.

    Featured Content Pro

    Support has always been rather scant for this plugin.

    Would you mind sharing, which ALTERNATIVE timeline plugin did you end up using ?

    Best of luck.

    Thread Starter hughes888

    (@hughes888)

    I got the problem resolved by using the plugin “HTTP Headers” by Dimitar Ivanov. In that plugin I went to ‘security’ and set “cross-origin-resource-policy” to “cross-origin”. Cleared all of the cache, etc. etc. and now it is working fine. I am also running on SiteGround and found that I had to disable NGINX and the options for combining CSS and combining JS cause my website seemed to get stuck trying to display the page. Now it seems to be working though.

    Would be interested to see what other timeline choices are out there.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Timeline Icons Not Displaying’ is closed to new replies.