Support » Fixing WordPress » Time zone not recognized after 5.3 update

  • Resolved rspwfaq

    (@rspwfaq)


    Ever since the WordPress 5.3 update, I’ve noticed that my scheduled posts via external editors are defaulting to UTC instead of the timezone that WordPress is set for in the settings. In my case, the Regina timezone. So for example, when I post something with a scheduled time of 7:30AM from Open Live Writer or the WordPress app on my phone, my WordPress site schedules it for 1:30AM instead. I need to actually create the post within WordPress and manually schedule the time in order to have it set to the time I want. This behavior is consistent across a few different external posting options I’ve tried so far (Live Writer, the app and setting a manual time offset via e-mail posting) and far as I can tell started with the 5.3 update. I read a suggestion elsewhere to add a line in the php.ini file with the desired timezone, but that had no effect when I tried it. I have verified in the settings that I have the correct timezone, and tried both “Regina” and “UTC – 6 hours” as options and both do the same thing.

    Any other suggestions I could try?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Aditya Kane

    (@adityakane)

    3rd party extrenal editors are not supported. Could you check and see if for some reason the timezone for your website has not reset?

    on the wp-admin Dashboard, look up Settings >> General

    Under that you should be able to check the timezone set on your WordPress website.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Also check your code in theme and plugins and ensure that in none of these you are changing the default timezone. WordPress sets the default timezone to UTC and then applies its own adjustments. If you change the default timezone, then you completely break how WordPress timezone handling works.

    Read this for more information: https://wordpress.org/support/topic/read-this-first-wordpress-5-3-master-list/#post-12124062

    For anyone else who might come across this page, in fact I discovered that the issue is that Open Live Writer is no longer currently being updated and is not compatible with WordPress 5.3 after the changes to time zone handling. So I’ve had to reluctantly switch to the WordPress.com desktop app instead, which has resolved the issue.

    Prediksi Jitu Togel

    (@nggrandong5758)

    I also experienced the same problem, sir.
    I have done several ways:
    1. Change the default theme, deactivate all plugins
    2. Clear browser cache
    3. Update PHP on the server to the latest 7.3 version and also set the PHP timezone
    4. Set the timezone on my server which is CentOS 7 x64
    5. Edit and set the timezone in the PHP.ini file

    But the problem still remained, I could not immediately publish my posts, the current solution was only to set back a few hours when I was going to post.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.