Support » Plugin: Woocommerce Open Close » Time only works on UTC no matter the local time

  • Resolved wesleyli

    (@wesleyli)


    Hello.

    I have a question about the time setting.

    My local time zone is Mountain Time (UTC -7).

    When I added a new WOC hour, it even shows my local time correctly when editing the schedule.

    However, I found out the time is not working as my local time. After reading posts in here and I checked, same as some people reported, the WOC hour plugin is ready the UTC time instead of my local time.

    Is there any way to adjust?

    The WOC I am using is the latest ver 2.5.7

    Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jaed Mosharraf

    (@jaedm97)

    Hello,
    We are really sorry for your problem.

    Did you setup the time correct timezone in WordPress default setting options. WOC is only works with timezone selection like this way:

    If your city is Dhaka and it’s following UTC +06.00, You can select either UTC +06.00 or Dhaka on WordPress settings, but this plugin will only work when you select Dhaka. Don’t worry this will not conflict with other things and we are trying to fix that dependency problem.

    If still you have problem, then Please check the settings from WOC, Did you set up the hours correctly or not.

    Let us know what happen, Thanks

    Plugin Author Jaed Mosharraf

    (@jaedm97)

    Hello @wesleyli,

    I think you are passing busy days. Nothing heard from you on this.

    I am marking this as resolved, Don’t worry if anything comes on this just let me know.

    Have a nice time, Thanks

    Hi Jaed:

    Thank you for the reply.

    We still have the problem, and once we spent more time on it, we found something was interesting.

    The thing is after installing WOC plugin, it will change the WordPress system time if we set the time to city and not to UTC format.

    We took a screenshot after we changed the Timezone to our city, Edmonton: https://imgur.com/s7pafpb

    As you can see, the UTC was 2018-03-04 21:25:38. Local time was 2018-03-04 14:25:38

    However, it was wrong. The correct UTC was 2018-03-05 04:25:38, and the correct local time was 2018-03-04 21:25:38

    Here is the screenshot after when we changed the Timezone to UTC-7 instead of Edmonton, then the time was back to correct: https://imgur.com/IqpGcNK
    (It shows UTC was 2018-03-05 04:26:57, Local Time was 2018-03-04 21:26:57. We changed within a minute after testing to change to our city Edmonton above)

    And if we deactivate the WOC, either we change to our city or UTC format, both are OK.

    Can you take a look on it? Thank you very much.

    • This reply was modified 1 year, 6 months ago by  wesleyli.
    • This reply was modified 1 year, 6 months ago by  wesleyli.
    • This reply was modified 1 year, 6 months ago by  wesleyli.

    Hello, any update?

    Thank you.

    Hello! Still looking for the follow up if it is possible.

    Thank you! 🙂

    Plugin Author Jaed Mosharraf

    (@jaedm97)

    Hi, there I missed the notification email for this support, don’t know how that happened, sorry for the delay.

    Okay, Can you please make this same thing on the demo website? I mean what you have done on your website, can you do the same on the demo website, so that I can directly look at that.

    Waiting to hear from you, Thanks

    Hello.

    I tried to log into your demo website: https://www.pluginbazar.net/demo/woocommerce-open-close

    And it seems like even your demo site has the same problem.

    After I logging into your demo site, then went to Setting > General

    Your Timezone was in Hong Kong. Here is the screenshot: https://imgur.com/M9OinFC

    The first thing I found out was the UTC was not correct already. In the screenshot above, your UTC is 2018-03-30 12:19, but the correct UTC at that time is 2018-03-30 4:20AM. Here is the screenshot I took on Google to check the UTC when testing: https://imgur.com/8M2KOGc

    After that, I tried to change to my time zone, Edmonton. Once I changed the time zone, the UTC changed to 2018-03-29 22:19 but also incorrect (again, correct one was 2018-03-30 4:20AM) Here is the screenshot: https://imgur.com/jn0b9lG

    You may also want to take a look on the demo.

    Again, in my case, if I deactivate WOC, my UTC and local time are correct, but once activated WOC, what I found is the UTC changed to my local time, and my local time also changed. Here is the screenshot: https://imgur.com/Dd32gZt

    These are what I found.

    Thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Time only works on UTC no matter the local time’ is closed to new replies.