Support » Plugin: Events Manager » Time is offset +6 hours

  • Resolved alagahd

    (@alagahd)


    All events are suddenly displayed with a time offset of +6 hours. I have verified that the server time zone is set to America/New_York (see https://weru.org/time.php). I have verified that WordPress time zone is set to America/New_York. I used Event Manager Options>General>Admin Tools (Advanced)>Reset Timezones to reset all Timezones to America/New_York.

    When editing the event, the proper time and date shows in the editable fields, but the time is +6 hours when viewed in Date and Time column of Dashboard>Events as well as on the public site.

    All our posted descriptions have been edited to show the times of the event, but the separate calculated time is also off by +6 hours.

    We are running: Events Manager Version 5.9.7.1 and Events Manager Pro 2.6.7 on WordPress 5.3.

    I am stumped. Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • Plugin Author Marcus

    (@netweblogic)

    Hi Everyone,

    Sorry that your times are showing differently in the new WP upgrade. However, I’m not able to reproduce this either.

    That said, a customer in the Pro forums very recently had this issue too, and whilst debugging their site it turned out that the Date Timpicker plugin was messing with the timezone calculations in #_EVENTTIMES. Disabling that made the problem go away.

    I’d suggest you try out EM with WP 5.3 and no other plugins just to see if the times are corrected. You can test this out without disabling anything and seeing it just yourself using my WP Safe Mode plugin.

    Plugin Author Marcus

    (@netweblogic)

    I should add, that if running EM without other plugins enabled (and also a default WP theme) still shows this problem, I’d ask you to get in touch via our contact page so I can take a closer look at your site.

    If it does turn out to be an EM issue, I’d need to reproduce the issue in order to fix it, currently, I can’t.

    johnlsaxon

    (@johnlsaxon)

    @netweblogic
    Thanks, Marcus, but before downgrading to WP 5.2.4, I tried running the site in Safe Mode using your app (which I guess disables all apps except EM) and WP 5.3 and times were still off.
    I do not see Date Timpicker installed as a plug in on our site.
    Problem went away when reset from WP 5.3 to WP 5.2.4.
    It came back again when Site Ground automatically updated to WP 5.3.1. Reset again to 5.2.4 and problem corrected itself.
    EM 5.9.7.1
    Wordpress UUA congregation theme
    Website: http://www.uuforwardtogether.org

    Plugin Author Marcus

    (@netweblogic)

    @johnlsaxon if you (or anyone with this problem) can get in touch so we can talk privately here or even via WP’s slack, that’d help me be able to reproduce this.

    Would it help to move the needle forward to a real solution to this 2-week old problem if we were to move to the premium version of EV?

    I’m having the same problem. Are there any updates on a fix besides reverting to an old version of WP?

    • This reply was modified 1 month, 2 weeks ago by theshae.
    travelgenee

    (@travelgenee)

    This problem is occurring on one of the WordPress sites I do for a non-profit. (caloundrafamilyhistory.org.au) Reverting to 5.2.4 did solve the date issues however I cannot use this version as our society library catalogue needs a more recent version. Does anyone know if anything is being sorted out by the EM developer so it plays nice with WP 5.3??
    Thanks.

    johnlsaxon

    (@johnlsaxon)

    Marcus, the developer, is aware of the problem so I think the best thing to do is for everyone who is having this problem to get in touch with him (directly through WP forum or Events Manager if necessary) to get this fixed.
    I’m still using the “fix” of reverting to 5.2.4 but that doesn’t seem to be a real “fix”.

    johnlsaxon

    (@johnlsaxon)

    Well, here’s one problem. The thread says this issue is resolved, but it’s clearly NOT resolved for some folks!!!

    Plugin Author Marcus

    (@netweblogic)

    Hi All, this isn’t an issue of going Pro or not, it’s a case of us being able to reproduce it. If it’s a bug, we’ll fix it regardless. However, as per WordPressw forum rules, we are strictly forbidden from requesting site access from users on the forum, so we can only provide that level of support to Pro customers.

    Currently, we cannot reproduce it ourselves, and the only Pro customer experiencing this issue as mentioned previously had a conflicting plugin and disabling that made the problem go away. My current recommendation as a first step to debug this:

    <p>I’d suggest you try out EM with WP 5.3 and no other plugins just to see if the times are corrected. You can test this out without disabling anything and seeing it just yourself using my WP Safe Mode plugin.</p>

    Additionally to this, make sure you’re also testing with a default WP theme such as twenty twenty or any of the twenty-something themes.

    travelgenee

    (@travelgenee)

    Hi Marcus, thanks for the suggestion to use the WP Safe Mode plugin however I was concerned that there was a comment that said their wp-config was deleted and one that said they had to restore their website. I realise it may have been operator error and not the plugin however I don’t wish to take the risk.

    Instead, I deactivated all plugins except for the Calendar and added back one at a time. Plus deleted cache loads of times as I went once the cache plug was available again.

    The times for events then were OK for all Plugins except Simple WordPress Membership which is the base to our membership module along with a number of added on plugins to increase its functionality. So I looked for any setting with Time Zone. In the advanced settings I UNTICKED:
    “Use WordPress Timezone
    Use this option if you want to use the timezone value specified in your WordPress General Settings interface.”
    Looks to be fixed. (happy dance)

    Notes – I used my usual theme because if it could not work with the theme I would have to change calendars.
    I had deactivated plugins most plugin previously but avoided my membership ones as I was frightened of losing data by deactivating. Hopefully the membership one is OK.

    I suggest people look as any plugins with the ability to set time zones.
    Thanks Fran

    johnlsaxon

    (@johnlsaxon)

    Thanks @travelgenee.
    I tried the use safe mode solution which should have disabled all other plugins but that didn’t work for me.
    I’ll try your solution of one by one and looking for timezone settings in each plugin.
    John

    We are frustrated that in the Advanced Tools, attempts to modify the default time zone from UTC to UTC-5 consistently fail. Using the dropdown to select the desired default time, then clicking the Reset button results in a screen refresh, but the default remains unchanged at UTC. Perhaps this is the source of our problem.

    Do we understand your message above that you are able to access sites that are PRO subscribers in order to provide a higher level of support? If so, we’ll sign up in a heartbeat.
    Michael

Viewing 13 replies - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.