• Hello,

    I have set from Events > Settings > Formatting > Date/Time > Time Format to 24h. But when I’m using [events_calendar long_events=1 full=1] the result is giving me 12h time format (2pm etc.) Please advice.

    Best regards,
    Nikola

Viewing 2 replies - 1 through 2 (of 2 total)
  • Events > Settings > Formatting > Date/Time > Use 24h Format? is only used when Creating events, not when displaying events. To change the time format for display, use Events > Settings > Formatting > Date/Time > Time Format. You should change it from “g:i a” to “G:i”. The formats are documented here: https://wordpress.org/documentation/article/customize-date-and-time-format/

    • This reply was modified 1 year, 3 months ago by joneiseman.
    Thread Starter nanera

    (@nanera)

    Hello,

    Thank you very much for your suggestion. I checked my settings and this fields was set in “H:i”. I have change it to “G:i”, but it didn’t solve the issue.

    However I paid more attention in this page settings and when I was looking for all the fields that are with Time Format I found in Calendar > Event format > #_12HSTARTTIME – #_EVENTLINK. Changing to #_24HSTARTTIME – #_EVENTLINK solve the issue. Thank you!

    Best regards,
    Nikola

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Time in 24h in calendar shortcode’ is closed to new replies.