Support » Fixing WordPress » Time & Datestamp format not updating

  • Hi there. I recently changed the format of my time/datestamp, but this doesnt show on my blog. I am the admin, and i did click save changes at the bottom of the page. 🙂 Everything else works fine. Any thoughts? Thanks for your help! S.

    ALso – I have several users, is it possible to post who the author is? i couldnt figure out how to do this in the options!

Viewing 9 replies - 1 through 9 (of 9 total)
  • I am using WP 1.51, and Apache 1.3x, Php 4.x if this helps!

    Look at the use of the_date() and the_time() tags in the templates of your active theme. Most likely they’re passing format strings to the date/time, for how to display it. If so, you’ll need to edit them.

    I have done that, to a point – I have not gone through EVERY file in the template dir, I have just went through the files that I can access through Presentation >> Theme Editor. I have gone through all of those, and made sure that things are what they should be, is there another file that I may have to go through that is passing and overwriting my format choice?


    Couple Qs:

    1. Theme in use?

    2. Exact portion of your pages where the date is not showing as expected?

    Using the Kubrick theme, and its in the sidebar – right under the Archives tag. Site is at in case that helps, or you needed it again.

    I checked your site and you have some very strange validation errors, but that is probably not your problem. What is evident is that the date format you are using is running all the numbers together.

    Formatting Date and Time takes you step by step through the process of setting your date format with the date or time tags.

    Please post your specific date or time PHP tag so we can check it out to see what the problem is. It should look something like this:

    <?php the_date('Y-m-d', '<h2>', '</h2>'); ?>

    Ah, the archive links. Well there’s not much one can about that, since the function that outputs the links (get_archives()/wp_get_archives()) is not filtering date info through any format. To change it would take some code hacking.

    I figured as much, been digging through the template_functions_general.php file and looking at the actual functions (get_archive, wp_get_archive) to see if I can fix it. With my limited knowledge of php, it might be more than I can handle. Time will tell.

    Lorelle –
    They run together because, well, thats just way that I wanted it – at least for now. Most, if not all, of the date time is like thus:

    <? php the_time(‘Ymd’); ?>

    About the validation thing – yeah, some of them are all me, but some of them, no matter what I change in whatever line has the ‘error’ it just comes back to another line – it displays like I want, so most of it I don’t care about.

    Thanks again – to the both of you

    There is a work-around to the category date display issue [that I’ve just found whilst building a template for my new blog which is only half way through so don’t be shocked if it breaks at the moment!!!].

    Anyway, the work around, is to use php AFTER the wordpress functions have done their bit. Using php’s date functions you can pretty much turn any date format into another format. You wouldn’t want to do this on huge number’s of dates but for a straightforward archive list I guess it’ll largely be ok.

    So, in get_archives I added after the line where $text is set…
    $newText = date("M y", strtotime($text));
    to change the standard archive link format [January 2006] to my preferred compact format [Jan 06].



Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Time & Datestamp format not updating’ is closed to new replies.