Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » Tiles could not be loaded – custom Maptiler image layer

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author RobertHarm

    (@harmr)

    Puh – actually I dont have a clue why the overlay doesnt get displayed. I found this in the leaflet git forum: https://github.com/CloudMade/Leaflet/issues/908 – but already tried on my site to exchange x/y – with the same result. Perhaps you could also open a request on leafletjs/github to get some additional support.
    Please let me know, if you find anything so I can add this to the next version of my plugin.
    thanks & sorry for not being able to help here…

    No problem Robert, thanks for the quick response. Hopefully I can get something useful for you. Your plugin looks very impressive and I’d like to see what I can do with it

    Robert, I had intended on using custom overlay layers for the custom image map, but didn’t get this to work. I did get it to work as a base layer though – the obvious difference between these layers being the TMS option (as mentioned in the link above), which I ticked yes for the base layer. There is no option for the overlay layer.

    “If true, inverses Y axis numbering for tiles (turn this on for TMS services)”

    Plugin Author RobertHarm

    (@harmr)

    tms changes the x/z/y part of the baseurl – try to do this manually at the overlay

    Plugin Author RobertHarm

    (@harmr)

    Hi again,
    just wanted to let you know that v3.1 will add an TMS option for custom overlays, allowing you to add overlays from tools like maptiler.
    regards,
    Robert

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    FYI: v3.1 with the option you need is available
    regards,
    Robert

    Hi,

    MapsMarker V 3.1 WordPress 3.4.2

    I have a similar problem. I have my tiles hosted on http://avetics.com/bukitbrownimages/{z}/{x}/{y}.png

    When I use it as a baselayer, it works. As in http://www.bukitbrown.sg. With the same settings, it does not work as an overlay. Any ideas?

    Settings used.
    TMS: True
    Min Zoom: 15
    Max Zoom: 19
    Enable continuousWorld? False
    Enable nowrap? False
    Show errorTile-images if map could not be loaded? False

    Any advice appreciated.

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    thanks for the report – TMS option for overlays seem to be broken on frontend. Will fix that with v3.2 and also add an option to remove the errortile-image from custom overlays
    regards,
    Robert

    Thats great. Do you know when will 3.2 be out?

    Plugin Author RobertHarm

    (@harmr)

    available since yesterday 😉

    Hi it works now. Thanks. Although on Google Maps as base layer the overlay appears to be “floating”. This is not the case if I use OSM.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Tiles could not be loaded – custom Maptiler image layer’ is closed to new replies.