Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Tiled mosaic images randomly not working

  • Resolved adamscottmartin

    (@adamscottmartin)


    Recently I noticed some of the images on my site are not loading the thumbnail. Checked my Media library and the image is working there. When adding my images to a Post I always use the tiled mosaic gallery.

    The odd thing is that I’m seeing this happen to older posts now (example: see the included link, image below “colors were starting to pop” text doesnt show). This worked when I originally made the Post and I’m not sure when it broke. All other images are still working.

    After reading many threads here, I’ve tried using Health Check (images work), disabling add-ons one-by-one (did not fix), and other troubleshooting. It seems most of the time broken images are served from i0.wp.com server and working images are from another Jetpack server (i1, i2).

    Only other recent changes are that I added SSL. Created 301 permanent redirect so I don’t think it’s a mixed content issue. Can’t figure out why only some of these are breaking at random.

    Any help is much appreciated, it’s starting to drive me crazy. Thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 16 through 20 (of 20 total)
  • Thread Starter adamscottmartin

    (@adamscottmartin)

    As mentioned earlier I am in the IT field with access to clean OS builds on a near daily basis. Can confirm images do not load properly for me on a clean Windows 10 build regardless of browser. Tested on clean loads of the latest Chrome, Firefox, IE, and Safari browsers. Turned off all Windows security features (i.e. defender suite on 10), verified no browser add-ins were installed. Tested on iOS (2 iPhones, 1 iPad) using Chrome, Firefox, and Safari as well with no add-ons.

    Have also tested from inside a corporate network, home network, mobile LTE network, and public wifi with same results. Confirmed at various geographic locations ranging between Milwaukee and Chicago.

    Thread Starter adamscottmartin

    (@adamscottmartin)

    Did some more testing. All plugins disabled besides Jetpack, theme set to default Twenty Nineteen. Tried in latest versions of Chrome, Firefox, and IE with the same errors.

    https://imgur.com/a/tASOK1k

    Plugin Support KokkieH

    (@kokkieh)

    Hi Adam,

    I asked a developer to take a look and he noticed that the original image file at https://adammartin.space/wp-content/uploads/20180706-ISP-LakeODalles2-01.jpg takes almost three seconds to load, despite the image being less than 500kB big. You should be able to see the same if you open that link, then reload it with your browser’s dev tools open on the Network tab.

    That points to a server issue as the problem here. What’s likely happening is that your server is struggling if it gets a few connections at once, for example, like when Photon visits the post to cache all the images. The images take too long to load, and as a result Photon fails, causing the image to not get cached properly.

    Please contact your hosting provider for help finding the cause for the slow load time for the images and fixing it.

    Thread Starter adamscottmartin

    (@adamscottmartin)

    Thanks KokkieH. I have checked with my hosts and confirmed server does not seem to be the issue. What is very strange is that upon publishing the original blog post images worked fine and only now are they dying. Hosting provider confirms server specs & bandwidth have actually increased since that time.

    Another oddity: If I re-upload the image with a different name and put that new image (same file size) into the post, Jetpack CDN will show the new file. Why would this work if my host has a server problem?? Not logical.

    I’m going shift my efforts now on optimizing the site further and testing other gallery plugins + CDNs. Temporarily I will probably re-upload the image to fix my posts and disable Jetpack. Adios.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    The issue could be intermittent, especially since it’s only 500kb but loading in over 3 seconds.

    The issue may only be happening during times of high server load, which if you’re on a share server will be hard to pin down, since you’re sharing resources with probably thousands of other sites.

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Tiled mosaic images randomly not working’ is closed to new replies.