Jetpack by WordPress.com
[resolved] Tiled Galleries Not Displaying (34 posts)

  1. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 2 years ago #

    This gallery setting problem could be why the fancybox elements don't get added to the code.

    Could you delete that gallery, and create it again from scratch while making sure it's set to "Media File"?

  2. 3cstudio
    Posted 2 years ago #

    Thanks Jeremy -- it's becoming clear that Jetpack is not at fault, so I'll try to take it up with lightbox plugin makers (of which none have responded in a week, but that's beside the point!). Thanks for your time/effort on my behalf, even when it isn't really your plugin's issues that are causing all the problems. Jetpack's Tiled Gallery looks fine -- the lightbox options are not working.

    Case in point: just got the 2nd lightbox item to work by (as you suggested) redoing the Gallery and tweaking the Appearance settings for that particular plugin -- but it only worked for the link: http://dev.cherrycountyplayhouse.org/scrapbook/tommy/, not for: http://dev.cherrycountyplayhouse.org/scrapbook/the-presidents/ etc. So, that is where I will have to dig further.

    Thanks again,

    Steve C.

  3. 3cstudio
    Posted 2 years ago #

    Just FYI, I found a "fix", though I'm not sure what did it -- seems to be a glitch in WordPress Galleries > Media File vs. Attachment Page settings...

    I got another tiled gallery to open lightbox images at: http://dev.cherrycountyplayhouse.org/scrapbook/the-presidents/

    What I did was Edit the gallery, and no matter what it said the Gallery "Link To" option was, I set it to Attachment Page, clicked Update Gallery, then the overall Update for the post. It gave (predictably) the attachment page.

    When I went back into edit the Gallery settings, I switched that to Media File, and Updated both it and the post/page. This 3rd changeover made the proper lightbox function.

    Now to do the same for 50+ other galleries... :-/ Unless you can spot the issue? I tried to reset Permalinks, as I noticed that sometimes fixes similar issues. No luck...


    Steve C.

  4. 3cstudio
    Posted 2 years ago #

    Also, another member alerted me to a known issue in WP3.5.1 -- for some reason, despite being marked as a link-to-media, the shortcode (in the Text tab) for the gallery is lacking:


    Adding that is the equivalent of doing the steps I previously mentioned. Hope that helps someone else in a similar predicament.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Jetpack by WordPress.com
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic