Support » Plugin: Events Planner » Ticket quantity defaults to 0

  • Resolved blackjaic

    (@blackjaic)



    I have created an event and set the minimum number of tickets that can be purchased to 1 and the maximum to 1. Despite this the default Quantity is set to 0. Zero shouldn’t even
    be an option. I’m using the Lite version of the plugin, and the price for the ticket is $0.

    Thanks for any information.

    https://wordpress.org/plugins/events-planner/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author abelony

    (@abelony)

    Hi blackjaic.

    I am very sorry but in the Lite version, the setting for hiding the 0 is not available. Very sorry.

    Thanks, Abel

    Why would you need a setting to hide the 0? You have a minimum number setting. It is a bug that you don’t honor that.

    Plugin Author abelony

    (@abelony)

    No, not a bug.

    For example, let’s say you have two or more prices (a lot of the users do). If let’s say you put a min of 1 and max of 5 and that hid the 0 in the quantity dropdowns, then for each one of the prices, the user will have no choice but to select a quantity of at least 1, which may not be the intent. That’s why the Pro version has a Show 0 setting for each price.

    Now, you don’t really have to get the Pro. If you are comfortable with making a quick change to PHP code, you can edit \events-planner\application\models\epl-registration-model.php, remove 0 => 0 from line 369 (http://screencast.com/t/tRM8qGYj)

    Hope this helps.

    Thanks, Abel

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Ticket quantity defaults to 0’ is closed to new replies.