Support » Plugin: WP-Stateless - Google Cloud Storage » Thumbnails created but not uploaded to GCS

  • Hello,

    Installed this plugin today – orginal files are being successfully uploaded from Media Library to GCS, but thumbnails and smaller sizes that WordPress generates as each is uploaded and not being transferred to GCS at all.

    When I upload an image in Media Libary I can see it successfully create all the various sizes/thumbnails on my web server, however only the original sized image is appearing in my GCS bucket (with all sizes then deleted from my server as per the stateless option chosen in settings).

    What is going wrong here?

    I have tried to regenerate images but that makes no difference at all.

    Thanks

    Glen

    Stateless Version 2.2.2
    Smush Version 3.0.2

    • This topic was modified 6 months, 2 weeks ago by  glenofcrawley.
Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Eric Sopp

    (@ideric)

    Hey Glen, you’re running in stateless mode – is that correct?

    To add to this, when I try to directly access the small thumbnail size URL, I get this error page:

    <Error>
    AccessDenied
    <Message>Access denied.</Message>
    <Details>
    Anonymous caller does not have storage.objects.get access to BUCKETNAME/FOLDER/JC0001-BMP-BDY-01-100×100.jpg.
    </Details>
    </Error>

    Yes, that’s right Eric : )

    Plugin Author Eric Sopp

    (@ideric)

    When you configured WP-Stateless initially, did you use the setup assistant or did you manually configure it?

    Manual setup instructions at https://github.com/wpCloud/wp-stateless/wiki/Manual-Setup

    I used the setup assistant. The only problem I had with that was that I wanted to rename the bucket. So, I deleted it on GCS, then removed the “Service Account JSON” and bucket name from settings, then re-ran the setup assistant. Could that have caused an issue here?

    • This reply was modified 6 months, 2 weeks ago by  glenofcrawley.
    Plugin Author Eric Sopp

    (@ideric)

    The Service Account JSON will grant access to Google Cloud Storage (GCS) on the GCP (Google Cloud Project) project. Changing the bucket on the same GCP project would not require you to change the Service Account JSON.

    Do you have this problem with WP-Smush disabled? I’m thinking there may be some thumbnail related setting you have enabled in WP-Smush that may causing some weird issue.

    Just tried that now – Smush disabled, uploaded a new file and the same thing happened, just the original size has uploaded to GCS

    Plugin Author Eric Sopp

    (@ideric)

    Can you link to the website where you seeing this problem?

    Also – what thumbnail sizes are not being syncronized with GCS?

    Every single thumbnail size is not uploading.

    I’ve just tested with Wp-Stateless in CDN mode, with Cache-Busting disabled. That still only allows the original image to be uploaded to GCS, but the thumbnails at least remain visible and not deleted in the media library.

    You can see the issue on this product page, where the original size image displays but thumbnails beneath all missing:

    LINK REMOVED

    At LINK REMOVED all smaller size thumbnails are missing.

    This is affecting any image upload, not just those for WooCommerce product pages btw.

    Thanks

    Glen

    • This reply was modified 6 months, 2 weeks ago by  glenofcrawley.
    Plugin Author Eric Sopp

    (@ideric)

    Hey Glen, I think we will need to take a closer look at your setup. Would you mind sending admin access to us?

    Please send (dashboard URL, username, and password) to anton.korotkov@usabilitydynamics.com and reference this issue in you remail.

    Thanks for helping on this Eric, I have email details now

    : )

    Sorry to jump on an old thread, but Google pointed me here. We’re having the same problem. We have six image sizes. When uploading an image we are getting 403 response from GCS, for all sizes. When regenerating the image, either by using “Regenerate and sync with GCS” or by using smushs “Restore” and then smushing the image again, all the image sizes are created in GCS.

    Did you guys solve the issue?

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.