WordPress.org

Support

Support » Plugins and Hacks » Fedmich's Facebook Open Graph Meta » [Resolved] Thumbs Not Appearing

[Resolved] Thumbs Not Appearing

  • Hi Fedmich,

    I am having the same issue. My thumbnail options all of a sudden dropped from 15 to 3 on FB recently, and this has happened before, … but they don’t seem to be coming back at all.

    So, I installed you plugin, but am not having any luck getting new thumbnail options.

    The site is http://www.crossfit-competitions.com, and the other plugins I am using are:
    Akismet
    All-In-One SEO Pack
    Facebook Comments
    Fast Secure Contact Form
    fbLikeButton
    Featured Content Gallery
    Google Analytics for WordPress
    Related Posts via Categories
    Shadowbox JS
    Taxonomy Dropdown Widget

    Any help you could give, I would appreciate, as I’m tired of using the same three (3) thumbnails that are provided to me, hah.

    Thanks!

    http://wordpress.org/extend/plugins/facebook-and-digg-thumbnail-generator/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author fedmich

    @fedmich

    Hey Buddy,
    Maybe this is because there is no og:description generated.

    http://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.crossfit-competitions.com%2F2013%2F02%2Fcivilian-military-combine-new-england-mountain-assault%2F

    I just uploaded v1.15.6, wait a while and update your WP,
    then go to settings and check the meta-description and save.

    Let me know when you have tried it so I could re-test it

    Thanks for the response.

    I updated the plugin, but … still not seeing any new thumbnail options when I paste a link into FB.

    Any other thoughts?

    Plugin Author fedmich

    @fedmich

    Did you goto the settings / fb thumbnail?
    and checked the meta description?

    or via this url
    http://www.crossfit-competitions.com / wp-admin/options-general.php?page=fbthu-options.php

    Hi Fedmich,

    I did NOT have “Add Meta og:description” checked, but it is now. And saved.

    Should changes take effect immediately?

    Thanks.

    I looked in the code …

    <!– Fedmich facebook/digg thumbnail v1.15.6 –>
    <meta property=”og:title” content=”RARE 10k Challenge (04/20/13)”>
    <meta property=”og:site_name” content=”CrossFit Competitions | Team Challenges | Throwdowns | Adventure Races | Weightlifting Events”>
    <meta property=”og:url” content=”http://www.crossfit-competitions.com/2013/02/rare-crossfit-rare-10k-challenge/”>
    <meta property=”og:locale” content=”en_us”>
    <meta property=”og:description” content=”Rare CrossFit (VA). April 20th, 2013. 9:00am.”>
    <link rel=”image_src” href=”http://www.crossfit-competitions.com/wp-content/uploads/2013/02/rare-crossfit-logo.png” />
    <meta property=”og:image” content=”http://www.crossfit-competitions.com/wp-content/uploads/2013/02/rare-crossfit-logo.png” />

    … and the file that is being shown is the one I am looking to use as my thumbnail, but FB is still giving me the same 3 thumbnail options. Not sure how to get it to recognize the new thumbnail I’m looking for.

    Plugin Author fedmich

    @fedmich

    its not immediately reflected.
    You cleared your cache on your server right?

    Let’s wait around 24 hours and check again.
    FB should refresh their cache then

    I have looked up how to clear the cache, and everything that folks are saying needs to be deleted, I am not finding on my server. Is it possible I don’t have any cache?

    Otherwise, can you walk me through what needs to be done, please.

    Thanks.

    Plugin Author fedmich

    @fedmich

    Perhaps you don’t have a cache on your server.

    But the generated code from your site should now be correct,
    your new posts should have the correct thumbnails.

    I’m still waiting for FB to clear out their cache,
    Will let you know when they have done so.

    Yes, please do.

    I have cleared my browser cache as well, and still seeing the same 3 thumbnail options.

    Thanks.

    Still no new thumbnails appearing.

    But now the wrong description is showing up too. I have the All-In-One SEO Pack plugin installed, and previously the description of the link was pulling from that description, but now the code for your plugin is generating the description from the excerpt.

    Any way to change that?

    And any clue as to why I’m still not seeing the thumb that should be there? Looking at the post code, your plugin is generating the correct link … FB just isn’t seeing it as an option.

    I just ran a debug check, and this came back …

    Small og:image: All the images referenced by og:image should be at least 200px in both dimensions. Please check all the images with tag og:image in the given url and ensure that it meets the recommended specification.

    … that have anything to do with it? The image I’m looking for on each post is 115×95.

    Plugin Author fedmich

    @fedmich

    Hello,

    The FB cache have changed,
    and yes it must be at least 200×200, sorry that I forgot to mention that.
    Make it bigger and lets try again.

    If you use All-in-one SEO pack to generate description, you could just uncheck my checkbox for the description if you want.

    Is this something new that the image has to be at least 115×95? Could this have been the issue all along? And I may not need any plugins at all … just need to make my images larger?

    I’m sorry, … something new that the image has to be at least 200×200. Because my images, since I started my FB page, have always been 115×95 … and this hasn’t been an issue.

    Plugin Author fedmich

    @fedmich

    yes that has been there before. I think around early of 2012

    If you dont use a plugin, FB may use a big photo from your sidebar
    like this for example
    http://www.crossfit-competitions.com/wp-content/themes/crossfit-competitions/images/wod-fuel-ad.jpg

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Resolved] Thumbs Not Appearing’ is closed to new replies.
Skip to toolbar