Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Thumbnails not generated in version 1.9.7

Viewing 15 replies - 1 through 15 (of 20 total)
  • I have version 1.9.7 and everything is working fine.

    Have you made any other changes? New plugins, upgrades, host?

    Are you getting any error messages?

    Try re-installing.

    Good luck.

    I’m also having trouble uploading a featured image. Anybody encounter/know how to fix this?

    Thanks.

    MarcelJomphe
    Did your issue get resolved?

    ntety

    Your trying to upload a featured image for a post I presume?

    I’m not sure how far you’ve gotten along in the process, but NextGen should have a tab in “Add featured image” where you can select from images uploaded to it.

    You can also just use images from the Media Library or upload them right in the featured image popup.

    You also have to make sure to click “Use as featured image” and not the “Insert into post” button.

    Lastly, your theme has to support featured images for them to display.

    Thank you for your reply. I am familiar with how to use NextGen and the Featured Image tool. I have had no problems with it in the past until two days ago.

    I have tried using several different browsers, updated the plugin, Deactivated and re-activated, all to no avail. I have tried uploading from every available source as well…

    NextGEN is getting stuck while “saving” the picture as the featured image. It just says “saving” and never proceeds. Anybody figure out how to get around this?

    Thanks again for any and all help…

    Yeah, sorry if I sound patronizing. I never know how savvy the person I’m replying to is, so I usually resort to the simplest explanation possible.

    Unfortunately it results in some completely useless answers…

    So, when you click “Use as featured image” it changes to “Saving…” and just freezes? No errors, nothing?

    In NextGen’s code, right after it does that, it uses the jquery post function to do the magic that actually sets the featured image.

    Is there a possibility you have multiple versions of jquery?

    Between plugins and themes, a jquery version or two can get included causing problems.

    It would be hard for me to debug why it’s not working for you without actually getting a look at your setup.

    Other random advice: Any other updates since it worked? Try disabling plugins etc. What changed two days ago ^_^?!?

    If you want to get down and dirty with the code, I would be willing to point you towards the relevant NextGen files and code that should be setting the featured post.

    Since you get the “saving…” that part works, but either the Jquery.post doesn’t work (because of multiple version of jquery) or the post never completes.

    There is plenty of error handling code in there, the link should say “error” if something goes wrong, or it should exit out in some other way.

    I actually just tested it (edited code to make it fail) and the error did show up in the box where the image should have been.

    The post seems to be the issue, at least according to the info I have.

    There is two different issues here.
    Ntety has an issue with the featured image, and it should not have been posted here, but rather in a new post.

    My issue was related to the creation of thumbnails when creating a new gallery. I deactivated the plugin “Justified Image Grid” which was the only new plugin I had installed recently, and created a new gallery, and the thumbnails were created without problems. So, I found what is causing the problem but don’t know how to fix it so I can continue to use the Justified Image Grid plugin and NextGen.

    smigliorato, I can’t thank you enough for your time and help. For some reason it works now! I appreciate your time and effort. I saved everything you wrote in case I have any issues in the future 🙂

    MarcelJomphe, didn’t mean to ruffle your feathers. This is my first WordPress post and I’ll be sure to make my next in the correct forum.

    No worries Ntety !

    So, does anyone have any answers to the initial post?

    I have just started trying to use the gallery, and I am having the same problem (though I am not using the image grid plugin as the op is).

    I have uninstalled and reinstalled.

    I get an error message in each case saying that the memory limit has been exceeded, and that 93 mb of memory (!!?) is required.

    My images are between 1 and 2 mb jpg files.

    Thoughts?

    MarcelJomphe
    I have something else to do right now, but I will take a look at nextgen + Justified Image Grid to see if I can narrow down the issue.

    Subscribe to the thread and I will have something for you (not necessarily a magic fix) no later than tomorrow evening-ish.

    Also, props for narrowing the issue down. That makes things much easier.

    jlbriggs

    Those are some pretty big files.

    I don’t know what they are, but I would suggest finding a way to make them smaller.

    I would resize them to make them smaller, and use a jpg compression setting like 60%-80%

    You are running into the PHP memory limit for your system. This is a different sort of issue than MarcelJomphe is having.

    Resize the images and find a way to get them smaller and that should go a long way towards fixing the issue.

    Helpful links

    http://stackoverflow.com/questions/985725/tools-for-jpeg-optimization


    http://luci.criosweb.ro/riot/

    If you don’t want to optimize the images, try the stuff below. It might not even be possible on your host though.

    Many hosts won’t allow you to change it, but they might do it for you.

    Go here and find the part on the page about PHP memory limit.

    You might need to change both the server and wordpress settings.

    96mb is a lot of memory. Shared hosts might not allow you that much, or charge you for it. I only use 32mb on my install. Increasing the limit is a bit wasteful, and overkill, in my opinion.

    I’m having the same issue where the thumbnails aren’t working in the NextGen Gallery. They also don’t show up when I upload a pix into the media gallery.

    Thoughts?

    Thanks!

    I had the same problem. I’m not totally sure what caused it, but here’s how I fixed it:

    Go to Manage Gallery, select the gallery in question, select all of the images (using the checkbox to select all id’s), under the bulk actions dropdown select “Create new thumbnails” and click apply.

    That should do the trick… At least it did for me anyway.

    Thanks, will give it a shot and let you know.

    Any thoughts on why the thumbnails and pix aren’t loading properly in the media gallery?

    Bradvader, unfortunately that didn’t work. Guess I will start to disable other plugins and see if there is a conflict.

    Thanks.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Thumbnails not generated in version 1.9.7’ is closed to new replies.