Support » Fixing WordPress » Thumbnails not generated in v2.6

  • They weren’t being generated in 2.5, and I upgraded hoping to solve the problem. Same problem in 2.6.

    When images are uploaded, they upload fine, however no Thumbnail is generated. When I try to insert the image, it inserts the full size image.

    I have tried smaller image sizes to see if maybe my images were big. No help.

    I have tried different types of images. No diff.

    I have tried the fixes listed by WordPress, including the functions.php. No help.

    I have searched these forums and see dozens of people having the same problem in 2.5 and 2.6 and being completely ignored. Is there no solution to this problem? This is a serious issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I seem to have the same problem after upgrading to 2.6. No thumbnails are generated in the media library. The same image that got a thumbnail in 2.5 don’t get one now when I upload it again. So for me it looks like something broke between 2.5 and 2.6. I’m running the latest version of FF on Ubuntu. The same behavior with both Flash upload and Browser upload. Thanks! -Arto

    If using custom media folders, you must specify the url location of that folder in settings->media
    otherwise wipe out the two settings completely and use the default, the thumbnails then appear.

    Hi, yes I in the mean time tested this on my experimental site which is “native” 2.6 (not upgraded from 2.5) and it worked. So I changed the media folder to the new default value and it did indeed work. Was there a change of default media folder perhaps that wasn’t properly handled in the upgrade or (alas) did I tweak the media folder location myself way back?

    Thank you for your answer!

    I suspect I have the same problem, but not the language to express it properly or understand the solutions above. Here is the problem I have.

    Links in my post-pages do not show a ‘thumbnail’ picture of the site being refered to. For example, the links in this post:

    public funded broadcasting

    When compared to my friends WordPress blog. For example, this post

    Stratfield Saye

    From the above discussion I think that I need to:
    “wipe out the two settings completely and use the default, the thumbnails then appear”

    Where/how do I ‘wipe out the two settings and use the default’ – is there a file in my installation that I can replace or edit? Can you point me to this file (e.g. in the 2.6 download hierarch folders, or via the admin panel) and clearly show what needs to be removed/replaced.

    Guys – thankyou for having these forums, they are much appreciated and have solved many of my challenges without my even having to post 🙂

    I’m not sure you’re having the same problem as I had. Mine was that I didn’t get any thumbnail images in Site Admin -> Manage -> Media Library.

    I think your friend has installed some fancy plugin that pulls content off the linked-to site and displays it in a window. I haven’t seen that on any other sites (including mine). Ask her!

    Anyway, to solve my problem I changed the upload folder under Site Admin – > Settings -> Miscellaneous to the indicated default value which is wp-content/uploads. The did the trick for me.

    Cheers! -Arto

    I’m experiencing the exact same issue. Upgrading from 2.5 to 2.6 seemed perfect at first, but then I started going back though my media library and saw that half my thumbnails were missing. I narrowed it down to the links being broken to the thumbnails for anything uploaded in 2.5, but anything uploaded in 2.6 still has their thumbnails. This, until updated from 2.6.1 to 2.6.2. I lost all my thumbnails again.

    If I try to add any of these files into a new post from the media library, just like you describe, word press only enter the HTML tag for the A REF, but not IMG SRC. The result is I get a blank image element(Showing correct alt text) that links to the correct file, but no file shown on the new post I just created. However, all old posts that contain that image work just fine because the HTML code created for them is still valid.

    Is there a setting that get’s redirected other than the one in the Admin area under Setting -> Mic. for the upload dir?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Thumbnails not generated in v2.6’ is closed to new replies.